enable devtools/scratchpad tests with e10s

RESOLVED FIXED in Firefox 37

Status

DevTools
Scratchpad
RESOLVED FIXED
4 years ago
9 days ago

People

(Reporter: harth, Assigned: past)

Tracking

(Blocks: 2 bugs)

unspecified
Firefox 37
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
All the scratchpad tests are disabled in e10s right now.
(Reporter)

Updated

4 years ago
Blocks: 875871
Blocks: 984139
tracking-e10s: --- → +
(Assignee)

Updated

4 years ago
Assignee: nobody → past
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Created attachment 8536622 [details] [diff] [review]
Make Scratchpad's reloadAndRun use the RDP and enable scratchpad tests with e10s

Fixing this wasn't too hard after all, there was only reloadAndRun that had to be modified to use the remote debugging protocol instead of reaching into content directly.
Attachment #8536622 - Flags: review?(fayearthur)
(Reporter)

Comment 2

4 years ago
Comment on attachment 8536622 [details] [diff] [review]
Make Scratchpad's reloadAndRun use the RDP and enable scratchpad tests with e10s

Review of attachment 8536622 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good as long as try is good. An e10s try run would be good as well.
Attachment #8536622 - Flags: review?(fayearthur) → review+
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1074231
https://hg.mozilla.org/mozilla-central/rev/c34f43a2a072
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1045841

Updated

9 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.