URL: with multiple question marks go to wrong page (encodes first ? -> %3F)

VERIFIED DUPLICATE of bug 110508

Status

()

Core
Networking
--
major
VERIFIED DUPLICATE of bug 110508
17 years ago
16 years ago

People

(Reporter: Neil Pryde, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I keep getting errors trying to read my e-mail, with build 2001111708, but prior
versions seems to work well.

Steps to reproduce:
1 - visit www.netscape.net
2 - click on the e-mail button
current result:

Not Found
The requested object does not exist on this server. The link you followed is
either outdated, inaccurate, or the server has been instructed not to let you
have it.

expected result: load page

NOTE: I do get a bunch of strict warnings (line 1189) and one JS error (line
1294) on the JS console.
(Reporter)

Comment 1

17 years ago
Forget about that error on line 1294. This error is caused by the MultiZilla
popup blocker, I don't see this error when I disable the popup blocker in the
QuickPref menu.

note: I just did a second test without MultiZilla installed, but still the same
problem, unable to read my e-mail.
URI parsing.

The "Mail" link redirects to a url of the form:

http://foo.netscape.com/bar?baz=quork&aaa=http://somewhere.somehow.com/file?c=d

Notice the presense of the two "?" characters.  Mozilla escapes the first one of
these, which causes things to break.  (the request is made to 
http://foo.netscape.com/bar%3Fbaz=quork&aaa=http://somewhere.somehow.com/file).
Escaping the second one instead works.

Netscape 4 seems to escape neither one, and therefore treats this as a request
to http://foo.netscape.com/bar which works.
Assignee: asa → darin
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
Severity: critical → major
*** Bug 110695 has been marked as a duplicate of this bug. ***
Summary: Can't check e-mail on netscape servers → urls with multiple question marks go to wrong page (encodes first ? -> %3F)

*** This bug has been marked as a duplicate of 110508 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
VERIFIED/dupe
Status: RESOLVED → VERIFIED
Summary: urls with multiple question marks go to wrong page (encodes first ? -> %3F) → URL: with multiple question marks go to wrong page (encodes first ? -> %3F)

Updated

16 years ago
QA Contact: doron → benc
You need to log in before you can comment on or make changes to this bug.