Events and red line are displayed incorrectly after Russian timezone update in 2014

RESOLVED DUPLICATE of bug 1090082

Status

Calendar
General
RESOLVED DUPLICATE of bug 1090082
4 years ago
4 years ago

People

(Reporter: Dmitry Veltishchev, Unassigned)

Tracking

Lightning 3.3

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8531189 [details]
thunderbird-russian-timezone-bug.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200257

Steps to reproduce:

I have Linux system (Ubuntu 14.04 in my case, but it does not matter) with fully up-to-date timezone information (tzdata package), which had been updated after Russian timezone change in October 2014.

My system timezone is set to Europe/Moscow (currently GMT +3:00), and same timezone in Calendar settings.
When I open Calendar tab in Thunderbird, I see red line displaying current time at incorrect position. It's at 14:18 on my screenshot, while current system time is 13:18.


Actual results:

Current time line in calendar view is shifted by one hour in future (please have a look at the attached file). It's shown at 14:18.


Expected results:

Current time line is displayed according current time, 13:18 in my case.
(Reporter)

Comment 1

4 years ago
Moreover, if I create event at 14:00, notification about event beginning is fired at 13:00. Same timezone problem, which is rather annoying.
Lightnings timezone database is out-of-date and doesn't contain timezone rules with the recent changes in Russia. See Bug 1009894 and its dependencies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1090082
You need to log in before you can comment on or make changes to this bug.