4.29% Linux|win|osx Dromaeo DOM regression on Inbound (v.36) Nov 25 from push 2e18a24f1298

RESOLVED WONTFIX

Status

()

Core
JavaScript: GC
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: jmaher, Assigned: jonco)

Tracking

({leave-open, perf, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Here is a graph that shows a regression in dromaeo dom:
http://graphs.mozilla.org/graph.html#tests=%5B%5B73,131,35%5D,%5B73,131,25%5D,%5B73,131,33%5D,%5B73,63,24%5D,%5B73,63,21%5D%5D&sel=1416762351536.7869,1416981463928.7175&displayrange=30&datatype=running

I had to backfill some data and I did some retriggers as this test is noisy:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&fromchange=feea8b1ea75f&tochange=e04692266f17&jobname=Ubuntu%20HW%2012.04%20x64%20mozilla-inbound%20talos%20dromaeojs

This is the push where we regress:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=2e18a24f1298

linux32: original range 880-900, after patch range of 869-870
linux64: original range 940-990, after patch range of 890-940
osx10.6: original range 820-850, after patch range of 790-820
osx10.8: original range 1060-1100, after patch range of 1020-1050
win7: original range 990-1020, after patch range of 950-980




This regression has now moved to Aurora, so when we fix this we need to uplift the patch to aurora as well.
(Assignee)

Updated

3 years ago
No longer blocks: 650161
(Assignee)

Comment 1

3 years ago
Created attachment 8533820 [details] [diff] [review]
bug1106784-dromaeo-regression

I've reproduced this on linux and confirmed that there is an effect, although the data is noisy.

One thing the original change did was to change the order of the nested for loops in GCRuntime::sweepBackgroundThings().  It's possible that this is causing the change in performance here.

Here's a patch to restore the original order.  Let's land this and see if it fixes the problem.

This also simplifies FinalizeTypedAreas() a little as I noticed that we never free empty arenas when sweeping in the background any more.
Assignee: nobody → jcoppeard
Attachment #8533820 - Flags: review?(terrence)
(Assignee)

Updated

3 years ago
Keywords: leave-open
(Reporter)

Comment 2

3 years ago
wow, thanks for jumping on this and bringing a fix to the table!
Attachment #8533820 - Flags: review?(terrence) → review+
(Assignee)

Comment 3

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/411d617e59a0
https://hg.mozilla.org/mozilla-central/rev/411d617e59a0
(Reporter)

Comment 5

3 years ago
if all is well here, I would like to see this uplift to aurora :)
Depends on: 1109913
(Assignee)

Updated

3 years ago
No longer depends on: 1109913
(Assignee)

Comment 6

3 years ago
(In reply to Joel Maher (:jmaher) from comment #5)
The patch didn't really seem to have any effect, but actually the scores seem to have improved a little since the original regression.
(Reporter)

Comment 7

3 years ago
dromaeo dom is one of the more noisier tests, I see what you mean about this not affecting the numbers so much.  Quite possibly we have done all we can reasonably do.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.