Links to clear history and remove cookies have lost their style

VERIFIED FIXED in Firefox 35

Status

()

Firefox
Preferences
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Ken Zalewski, Assigned: aryx)

Tracking

({regression})

34 Branch
Firefox 37
regression
Points:
---
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox34- wontfix, firefox35+ verified, firefox36+ verified, firefox37+ verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Go to Options -> Privacy.

In the History group box, make sure "Remember history" is selected.



Actual results:

The links for "clear your recent history" and "remove individual cookies" have lost their style.  There is no visual indicator that "clear your recent history" and "remove individual cookies" are selectable.



Expected results:

In versions of Firefox prior to 34.0, the "clear your recent history" and "remove individual cookies" links were properly styled, clearly indicating that they are selectable links.

Comment 1

3 years ago
Regression range:
good=2014-08-26
bad=2014-08-27
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dc352a7bf234&tochange=0753f7b93ab7

Birunthan Mohanathas — Bug 1009370 - Part 1: Move .inline-link style from preferences.css to common.inc.css. r=Unfocused
Blocks: 1009370
Status: UNCONFIRMED → NEW
status-firefox34: --- → affected
tracking-firefox35: --- → ?
tracking-firefox36: --- → ?
tracking-firefox37: --- → ?
Component: Untriaged → Preferences
Ever confirmed: true
Flags: needinfo?(birunthan)
Keywords: regression

Comment 2

3 years ago
[Tracking Requested - why for this release]:
tracking-firefox34: --- → ?
Ken, could you please attach a screenshot of the bug and maybe another one for the expected look?
Flags: needinfo?(ken.zalewski)

Comment 4

3 years ago
Created attachment 8532049 [details]
screenshot-links_missing.png

I attached a screenshot.
Flags: needinfo?(ken.zalewski)
(Reporter)

Comment 5

3 years ago
Thanks Loic.

Your screenshots match the link style problem that I am seeing.  It's very straightforward.  The two links were previously styled to appear selectable, and now they are not.

In my opinion, these links should be buttons, to make it clear that they can be clicked and that they will open new dialogs.  For now, however, I'll be happy just to see the styled links restored.
tracking-firefox37: ? → +
This isn't a severe enough issue to fix in 34. I have tracked for other releases as I think that we should take the fix in 35+.
status-firefox34: affected → wontfix
status-firefox35: --- → affected
status-firefox36: --- → affected
status-firefox37: --- → affected
tracking-firefox34: ? → -
tracking-firefox35: ? → +
tracking-firefox36: ? → +
Flags: firefox-backlog?
Created attachment 8536222 [details] [diff] [review]
patch, v1
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #8536222 - Flags: review?(dao)

Updated

3 years ago
Duplicate of this bug: 1111485

Updated

3 years ago
Attachment #8536222 - Flags: review?(dao) → review+

Updated

3 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

3 years ago
Flags: firefox-backlog? → firefox-backlog+
Flags: needinfo?(birunthan)
Created attachment 8537309 [details] [diff] [review]
patch, v2, r=dao

From #developers:
[2014-12-15 10:22:50] * Archaeopteryx * Tomcat|sheriffduty: hi, do i need a try run for a m-c patch which only reverts some css removal? bug 1106792
[2014-12-15 10:26:51] * Tomcat|sheriffduty * Archaeopteryx: well depened if you think this is trivial and don't break any test then its fine
Attachment #8536222 - Attachment is obsolete: true
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/c2af7ad0a783
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/c2af7ad0a783
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox37: affected → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 37

Updated

3 years ago
Iteration: --- → 37.2
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Contact: camelia.badau
Can we get a nomination for uplift here?  This needs to be nominated before Mon Dec 22 beta.
Flags: needinfo?(archaeopteryx)
Comment on attachment 8537309 [details] [diff] [review]
patch, v2, r=dao

Thank you for the reminder.

Approval Request Comment
[Feature/regressing bug #]: Bug 1009370
[User impact if declined]: Links 'clear your recent history' and 'remove individual cookies' in the Privacy pane of the Preferences window (which we still use for beta and release) won't be recognizable as links
[Describe test coverage new/current, TBPL]: Tested with nightly build
[Risks and why]: minimal (only CSS changes which are reverts)
[String/UUID change made/needed]: none
Flags: needinfo?(archaeopteryx)
Attachment #8537309 - Flags: approval-mozilla-aurora?
Comment on attachment 8537309 [details] [diff] [review]
patch, v2, r=dao

Approval Request Comment
[Feature/regressing bug #]: Bug 1009370
[User impact if declined]: Links 'clear your recent history' and 'remove individual cookies' in the Privacy pane of the Preferences window (which we still use for beta and release) won't be recognizable as links
[Describe test coverage new/current, TBPL]: Tested with nightly build
[Risks and why]: minimal (only CSS changes which are reverts)
[String/UUID change made/needed]: none
Attachment #8537309 - Flags: approval-mozilla-beta?
Attachment #8537309 - Flags: approval-mozilla-beta?
Attachment #8537309 - Flags: approval-mozilla-beta+
Attachment #8537309 - Flags: approval-mozilla-aurora?
Attachment #8537309 - Flags: approval-mozilla-aurora+
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using latest Nightly 37.0a1 (buildID: 20141221030204).
Status: RESOLVED → VERIFIED
status-firefox37: fixed → verified
https://hg.mozilla.org/releases/mozilla-aurora/rev/9283386f21ca
https://hg.mozilla.org/releases/mozilla-beta/rev/d81ece962ab2
status-firefox35: affected → fixed
status-firefox36: affected → fixed
Duplicate of this bug: 1107800
Verified fixed on latest DevEdition, build ID: 20141223004006.
status-firefox36: fixed → verified
Verified fixed on Firefox 35 Beta 8, buildID: 20141229214612.
status-firefox35: fixed → verified
Duplicate of this bug: 1108432
Duplicate of this bug: 1103643
You need to log in before you can comment on or make changes to this bug.