[RTL]When text is in a local that has text RTL gallery images brakes

RESOLVED DUPLICATE of bug 1087060

Status

Mozilla Localizations
ar / Arabic
RESOLVED DUPLICATE of bug 1087060
3 years ago
a year ago

People

(Reporter: RJ, Unassigned)

Tracking

unspecified
x86
Linux

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.2-exploratory-1])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8531268 [details]
logcat_20141202_0941.txt

Description:
In RTL text languages viewing image in gallery causes a visual break in the preview, and adds a second back button  


Repro Steps:
1) Update a Flame to 20141202001201
2) Set the device language to arabic
3) Reboot the device
4) Launch gallery
5) Select an image

Actual:
Screen appears broken and there are two back buttons 


Expected:
Correctly placed back button and no visual errors 

Environmental Variables:
Device: Flame 2.1
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency:100%
See attached: screenshot,logcat
Flags: needinfo?(dharris)
(Reporter)

Updated

3 years ago
Summary: [RTL]When text is in a local that has text RTL breaks gallery images → [RTL]When text is in a local that has text RTL gallery images brakes
(Reporter)

Comment 1

3 years ago
Created attachment 8531269 [details]
2014-12-02-12-28-57.png
(Reporter)

Comment 2

3 years ago
Issue is  affected on 2.1 flame and 2.0
Gallery display is broken in RTL

Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Device: Flame 2.0 (319mb) (Kitkat Base)(Full flash)
Build ID: 20141201000201
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: c756bd8bf3c3
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Issue does not occur on 2.2

Flame 2.2

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
The issue reported is fixed in 2.2 and can be resolved duplicate of bug 1087060.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?
Resolution: --- → DUPLICATE
Duplicate of bug: 1087060
You need to log in before you can comment on or make changes to this bug.