Closed Bug 1106825 Opened 5 years ago Closed 2 years ago

Faulty ooyala video play detection - MP4 video shows error of "video is not encoded for this device"

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: donrhummy, Unassigned)

Details

(Whiteboard: [contactready] [m3u8] [lib-ooyala] [android-enable-hls])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0
Build ID: 2014012800

Steps to reproduce:

Went to this link to watch video:
http://www.mmafighting.com/2014/12/1/7309317/the-mma-hour-with-alexander-gustafsson-scott-coker-roxanne-modafferi

Using: nexus 9, Android 5.0


Actual results:

In Chrome for Android, it plays, but Firefox displays an error stating it's not encoded for this device (obviously incorrect).


Expected results:

It should have played using the decoders on the device.
This is a player issue. I see the same thing in desktop loading the player with a mobile user-agent.

http://player.ooyala.com/v3/df56043a8061451d89897bbd6ee37d9a?namespace=OO&platform=html5-fallback&tweaks=android-enable-hls

Perhaps their attempting to load HLS which Gecko doesn't support and their do a platform detection on UA.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 34 → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → Android
Hardware: x86_64 → ARM
Summary: MP4 video shows error of "video is not encoded for this device" but it plays in Chrome → Faulty ooyala video play detection - MP4 video shows error of "video is not encoded for this device"
There's an inline script that sets the following option:

window.ooyala_options = {"tweaks":"android-enable-hls"};

So in the ooyala player itself, in the supportedVideoTypes function:

return e.tweaks["android-enable-hls"] && e.isAndroid4Plus ? {
  m3u8: !0,
  mp4: !0
}

(We count as Android4Plus because we match on /Android [23]/).

Unfortunately they only do canPlayType feature detection for non-Android devices--so the only way to get HLS (which presumably Chrome supports) is to set this option. We could reach out to mmafighting and ask that they disable this option--but we probably want to contact Ooyala as well. I don't see why they don't detect HLS with canPlayType for Android browsers as well.
Whiteboard: [contactready][m3u8]
(In reply to Mike Taylor [:miketaylr] from comment #2)
> (We count as Android4Plus because we match on /Android [23]/).

*because we don't match.
I have the same problem ,especially when trying to view videos on http://pornoreino.com/videos/nena-hermosa-blanca-lluvias-abby-le-gusta-tasle-el-pene-de-su-padrastro-negro ( sorry best example I had at hand ). Have this problem on my lg g3 device , tried on a friends Samsung and works just fine.

Mozilla/5.0 (Linux; U; Android 4.0.3; ko-kr; LG-L160L Build/IML74K) AppleWebkit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
Whiteboard: [contactready][m3u8] → [contactready] [m3u8] [lib-ooyala] [android-enable-hls]
This is working for me now, as well as the (NSFW) video in Comment #4. Let's close as FIXED.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.