[Browser] Selecting the Rocketbar and switching view from landscape to portrait (or vice versa) breaks the view.

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jthomas, Assigned: alive)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-1][systemsfe], URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8531308 [details]
logcat_20141202_1040.txt

Description:
After launching the Browser app if the user selects the Rocketbar and then changes the view from portrait to landscape (or vice versa) the browser app view will not display correctly.

Repro Steps:
1) Update a Flame to 20141202001201
2) Launch Browser App.
3) Select Rocketbar
4) Flip device to Landscape Mode
5) Click elsewhere in Browser
6) Observe the browser sizing behaviour.

Actual:
Browser view does not fit correctly after switching views.


Expected:
It is expected that the Browser view will fit accordingly when changing the view mode.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141202040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency:100%
See attached: Logcat & Video
Video: https://www.youtube.com/watch?edit=vd&v=jz86cc5b6gY
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
This issue does NOT occur on Flame 2.1 KK (319mb) 

Result: Device can be changed from Landscape mode and Portrait while in browser app successfully

Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


--------------------------------------------------------------
This issue does NOT occur on Flame 2.0 KK (319mb) 

Result: Currently the Landscape mode is not functioning for the 2.0 in Browser and Gallery due to the follwing bug.
https://bugzilla.mozilla.org/show_bug.cgi?id=1106853

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121000203
Gaia: 626d4d11a8c7e55022c1f364abb72ea340e2f1e7
Gecko: 74a294e72d0a
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Whiteboard: [2.1-exploratory-3]
Nominating to block on 2.2. This is poor UX and very easy to reproduce. Also a regression
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regression, regressionwindow-wanted
Whiteboard: [2.1-exploratory-3] → [2.2-exploratory-1]
blocking-b2g: --- → 2.2?
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141125224734
Gaia: 99d24c8f931f9d665652fbdd8b66926d8fcffb10
Gecko: 0473d796f375
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141125231735
Gaia: 6af28285cdaa0551782cecdb48bfc8a86c8257db
Gecko: 37c56d9b194c
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 6af28285cdaa0551782cecdb48bfc8a86c8257db
Gecko: 0473d796f375

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: 99d24c8f931f9d665652fbdd8b66926d8fcffb10
Gecko: 37c56d9b194c

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/99d24c8f931f9d665652fbdd8b66926d8fcffb10...6af28285cdaa0551782cecdb48bfc8a86c8257db

Possibly caused by Bug 1096133.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
possibly caused by patch for Bug 1096133 - can you take a look Alive?
Flags: needinfo?(jmitchell) → needinfo?(alive)
QA Contact: pcheng
Assignee: nobody → alive
Component: Gaia::Browser → Gaia::System
Flags: needinfo?(alive)
blocking-b2g: 2.2? → 2.2+
Any updates here?
Not knowing I am having 2.2+. repriorizing.
Adding Tim and Kevin for the prioritization question.
Flags: needinfo?(timdream)
Flags: needinfo?(khu)
I think Alive was meant to say he didn't see this got plus'd and he is re-priorizing his queue to work on this.
Flags: needinfo?(timdream)
Flags: needinfo?(khu)
Created attachment 8537615 [details] [review]
[PullReq] alivedise:bugzilla/1106855/do-not-block-system-resize-on-rocketbar to mozilla-b2g:master
Comment on attachment 8537615 [details] [review]
[PullReq] alivedise:bugzilla/1106855/do-not-block-system-resize-on-rocketbar to mozilla-b2g:master

The solution is not perfect so open to ideas.
Basically the problem is: we should only block the keyboard-resize due to hierarchy, but still propagate all other system-resize to all modules no matter it is top most or not.

In current stage it's difficult to distinguish these two events (keyboard-resize and non-keyboard-resize) and I don't want to change too much here.

Read through resize functions I think it deserves certain clean-up (for example, why this.width is not equal to this.element.width when handling orientationchange?), but not in a blocker.

What do you think?
Attachment #8537615 - Flags: review?(etienne)
Comment on attachment 8537615 [details] [review]
[PullReq] alivedise:bugzilla/1106855/do-not-block-system-resize-on-rocketbar to mozilla-b2g:master

r=me with the comment on github addressed, at least with a big comment in the code :)

The orientation change support for integration tests can't come quickly enough...
Attachment #8537615 - Flags: review?(etienne) → review+
(In reply to Etienne Segonzac (:etienne) from comment #11)
> Comment on attachment 8537615 [details] [review]
> [PullReq] alivedise:bugzilla/1106855/do-not-block-system-resize-on-rocketbar
> to mozilla-b2g:master
> 
> r=me with the comment on github addressed, at least with a big comment in
> the code :)
> 
> The orientation change support for integration tests can't come quickly
> enough...

PR updated, waiting tree green.
https://github.com/mozilla-b2g/gaia/commit/8a7377c1a75c25b90313f4d4606c7c25bab3a03a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED

Comment 14

4 years ago
Verified the issue is fixed on Flame 2.2

Switching view from landscape to portrait (or vice versa) doesn't break the view

"Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Whiteboard: [2.2-exploratory-1] → [2.2-exploratory-1][systemsfe]
Created attachment 8543833 [details] [review]
[PullReq] alivedise:bugzilla/1106855/do-not-check-frame-size-on-resizing to mozilla-b2g:master
QA Whiteboard: [QAnalyst-Triage → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.