[Email]After first email sign in reseting phone before setup is complete will yeild unintended result

RESOLVED DUPLICATE of bug 1106888
(NeedInfo fromanyone)

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 1106888
3 years ago
3 years ago

People

(Reporter: RJ, Unassigned, NeedInfo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-1], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8531309 [details]
logcat_20141202_1216.txt

Description:
After first email sign in reseting phone before setup is complete will case relaunch to flash the Email Ftu to pop on screen for a few seconds 

Prereq: have no emails signed in
Repro Steps:
1) Update a Flame to 20141202040207
2) Sign in to the email app 
3) After being logged in and user is on set up after first sign in reset the phone


Actual:
the FTU email screen pops up before the full email app is shown


Expected:
Email app is shown

Environmental Variables:
Device: Flame 2.2  (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency:100%
See attached:logcat,video clip:https://www.youtube.com/watch?v=nMQNnlJv7mk
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
Issue is not  affected on 2.1 flame and 2.0
Ftu pops up before email app is launch

Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0

Device: Flame 2.0 (319mb) (Kitkat Base)(Full flash)
Build ID: 20141201000201
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: c756bd8bf3c3
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Even though this bug predates bug 1106888, marking this one as a duplicate, since the other has a specific description of a fix that applies for a few different edge cases, and there have been other bugs in the past filed for the same underlying issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106888
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?
You need to log in before you can comment on or make changes to this bug.