[Lockscreen][RTL] Camera icon with passcode screen is located on the right, causing the time display shifted to the left

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Lockscreen
P2
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: Nefzaoui)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-exploratory-1])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8531329 [details]
LockscreenIssueWithRTL.png

Description:
When the device is set to a right-to-left language, the carmera icon on the lockscreen with passcode is not located on the left side of the screen properly. This causes the time display to be shifted towards the left and not aligned properly.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141202040207
2) Go to Settings > Language > Set the language in Arabic.
3) Go to Settinngs > Screen Lock > Enable Passcode Lock.
4) Press the power button twice to bring the lockscreen.
5) Slide the button to the right to unlock.
6) Observe the unlock screen with the passcode.
  
Actual:
The camera icon is located on the right, and the time display is shifted towards left.
  
Expected: 
The camera icon is located on the left, and the time display is aligned correctly on the right.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb, KK, Full Flash)
BuildID: 20141202040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
This issue does NOT reproduce on Flame 2.1. It was fixed in bug 964037 and bug 1042879.
Result: 

Device: Flame 2.1 (319mb, KK, Full Flash)
BuildID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.2-exploratory-1]
(Reporter)

Comment 2

4 years ago
Created attachment 8531330 [details]
logcat_20141202_1352.txt
(Reporter)

Updated

4 years ago
Blocks: 964037
Delphine, can you please weigh in on whether or not this should be a blocker?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(lebedel.delphine)
Keeping the needinfo on me for this one. Given some changes in schedule focus, I need to evaluate in the upcoming days how to treat this bug. Thanks!
This will not be a blocker for 2.2. at this point
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(lebedel.delphine)
Created attachment 8547606 [details] [review]
[PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Comment on attachment 8547606 [details] [review]
[PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master

Please review?
Thanks:)
Attachment #8547606 - Flags: review?(alive)
Comment on attachment 8547606 [details] [review]
[PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master

Greg shall own this.
Attachment #8547606 - Flags: review?(alive) → review?(gweng)
I think you may ask UI review at the same time since this is a purely UI change. To get an UI review+ is necessary.
Flags: needinfo?(nefzaoui)
(Assignee)

Updated

3 years ago
Flags: needinfo?(nefzaoui)
Attachment #8547606 - Flags: ui-review?(swilkes)

Comment 10

3 years ago
Ahmed, can you attach a screenshot? I'm having trouble getting patches with almost zero Internet in Mexico. I WILL be back in the U.S. tomorrow if this can wait until then. So sorry for the inconvenience!
Flags: needinfo?(nefzaoui)

Updated

3 years ago
See Also: → bug 964037
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2

Comment 12

3 years ago
Comment on attachment 8547606 [details] [review]
[PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master

Reassigning ui-review? to Rob since I'm buried in V3 work right now and blocking this.
Attachment #8547606 - Flags: ui-review?(swilkes) → ui-review?(rmacdonald)
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Comment on attachment 8547606 [details] [review]
[PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master

Thank you.
Attachment #8547606 - Flags: ui-review?(rmacdonald) → ui-review+
Comment on attachment 8547606 [details] [review]
[PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master

It's OK from the code level and passed UX review, thanks.
Attachment #8547606 - Flags: review?(gweng) → review+

Updated

3 years ago
Assignee: nobody → nefzaoui
(Assignee)

Comment 16

3 years ago
Thanks!
Flags: needinfo?(nefzaoui)
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 18

3 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #8)
> Comment on attachment 8547606 [details] [review]
> [PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master
> 
> Greg shall own this.

Alive, could you please give the PR an additional r+ so that Autolander lands it?
Thanks!
Flags: needinfo?(alive)
Flags: needinfo?(alive)
Attachment #8547606 - Flags: review+
(Assignee)

Comment 19

3 years ago
Thanks!
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

3 years ago
Comment on attachment 8547606 [details] [review]
[PullReq] anefzaoui:bug-1106879 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Lack off RTL support.
[User impact] if declined: Camera icon misplaced.
[Testing completed]: Yes, Flame.
[Risk to taking this patch] (and alternatives if risky): none, changes only RTL-related style.
[String changes made]: No string changes.
Attachment #8547606 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8547606 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/312f31716545ac207491ab99e1d07d1fc30df467
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S5 (6feb)

Comment 23

3 years ago
This issue has been verified successfully on Flame 2.0/3.0.
Reproduce rate:0/5
Attachment:Verify_RTL_PINCamera.png

Flame 2.2 build:

Build ID               20150204002509
Gaia Revision          a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gaia Date              2015-02-04 00:41:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8669c26fd4a5
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.035932
Firmware Date          Wed Feb  4 03:59:42 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:

Build ID               20150204010225
Gaia Revision          dfebaaa8aab43470f482d09d71137bab840c3ae9
Gaia Date              2015-02-03 18:49:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0c2f7434c325
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.043856
Firmware Date          Wed Feb  4 04:39:07 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified

Comment 24

3 years ago
Created attachment 8559545 [details]
Verify_RTL_PINCamera.png

Comment 25

3 years ago
(In reply to Coler from comment #23)
> This issue has been verified successfully on Flame 2.0/3.0.
The device are Flame 2.2/3.0.
You need to log in before you can comment on or make changes to this bug.