[email] Clear cookie cache once account creation starts

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jrburke, Assigned: jrburke)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
There are a couple of edge cases where the cookie cache could show the incorrect state temporarily:

* Starting account setup, and finishing it, but not going to the message list before the app is killed.
* If there are two accounts and the second one does not have any messages in the inbox, the cookie cache could still have the state from the first account, and that is shown for a moment before the second account with no messages is shown.

These edges can be avoided by just clearing the cookie cache when the account create process goes past the first screen.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1106856
(Assignee)

Comment 2

3 years ago
Created attachment 8531349 [details] [review]
GitHub pull request

Clears the HTML cache when the setup_account_info goes to the next card.
Attachment #8531349 - Flags: review?(bugmail)
Comment on attachment 8531349 [details] [review]
GitHub pull request

Looks good!
Attachment #8531349 - Flags: review?(bugmail) → review+
(Assignee)

Comment 4

3 years ago
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/984e6d79aa799d2695f9ca132dfdc1665a56c019

from pull request:
https://github.com/mozilla-b2g/gaia/pull/26596
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1157099
You need to log in before you can comment on or make changes to this bug.