[Window Management] Status Bar is blank when making or receiving a call while in an app

RESOLVED DUPLICATE of bug 1107355

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1107355
3 years ago
3 years ago

People

(Reporter: AdamA, Assigned: mancas)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing] [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8531353 [details]
logcat

Description:
When the user is making or receiving a call while in an app the status bar at the top of the screen is a blank black bar. While on the home screen there is a status bar present. Since calls are almost always made from the dialer there will never be a status bar when making a call.

Repro Steps:
1) Update a Flame to 20141202040207
2) Open dialer app 
3) Make or receive a call
4) Observe Status bar

Actual:
The status bar is blank while in calls

Expected:
it is expected that the status bars appear normally

Environmental Variables:
Device: Flame 2.2 (319mb)(Full Flash)
Build ID: 20141202040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 5/5
See attached: screenshot, logcat

-----------------------------------------------------------------
This issue also occurs on 2.1 Flame and the previous 2.2 Flame.

Environmental Variables:
Device: Flame 2.2 (319mb)(Full Flash)
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (319mb)(Full Flash)
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
the status bar is blank while in a call
(Reporter)

Comment 1

3 years ago
Created attachment 8531354 [details]
Making call
(Reporter)

Comment 2

3 years ago
Created attachment 8531355 [details]
Receiving Call
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

3 years ago
Whiteboard: [2.2-Daily-Testing]
qawanted for branch checks, I believe this is a regression.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Contact: jmitchell
[Blocking Requested - why for this release]: Regression, broken Functionality (status bar should always show icons / info)


issue does NOT occur on 2.0

Device: Flame 2.0
Build ID: 20141202035701
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: 29222e215db8
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
blocking-b2g: --- → 2.1?
status-b2g-v2.0: --- → unaffected
Keywords: qawanted → regression, regressionwindow-wanted
b2g34_v2_1 Regression Window:

Last Working:
Device: Flame 2.1
Build ID: 20141125135229
Gaia: b711909aab9a5cb84cba45175b909ad7f7b63842
Gecko: 6da00aa9b3ff
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken:
Device: Flame 2.1
Build ID: 20141125162631
Gaia: f20bbb0e24c065499df176a390c6d0e45d90eeb3
Gecko: 02527b2e1603
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: b711909aab9a5cb84cba45175b909ad7f7b63842
Gecko: 02527b2e1603
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: f20bbb0e24c065499df176a390c6d0e45d90eeb3
Gecko: 6da00aa9b3ff

GAIA pushlog: https://github.com/mozilla-b2g/gaia/compare/b711909aab9a5cb84cba45175b909ad7f7b63842...f20bbb0e24c065499df176a390c6d0e45d90eeb3

------------------------------------------------------------------------------------------------------

Guillaume - it looks like some of your changes to attention window dimensions may be responsible for this bug. Can you take a look?
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(gmarty)
Keywords: regressionwindow-wanted
QA Contact: jmitchell
(Assignee)

Comment 6

3 years ago
I'm working on this issue. It seems that attention window dimensions don't are responsible in this case. What I've detected is that when the attention window is opened, the status bar icons (minimized) are hidden with this css rule:

#screen.attention #statusbar-minimized {
    display: none;
}

When we are in an app, the status bar displayed is the maximized, so this is the cause because we don't see the icons. So we have a possibility here:
Update the status bar when the attention window is opened, in order to show the maximized.
However I don't really know if the attention window must be displayed with all the icons. AFAIK, the status bar activates or deactivates the clock when the window is open or close. So, Etienne, what we should do in this case, show all icons, or just the clock?

Thanks
Assignee: nobody → b.mcb
Flags: needinfo?(etienne)
That's a UX question :)
Flags: needinfo?(etienne) → needinfo?(rmacdonald)
Blocking as this is a regression, I'd prefer a backout to fix this if  we can than taking more forward fixes at this time.
blocking-b2g: 2.1? → 2.1+

Updated

3 years ago
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing] [systemsfe]
I requested 2.1+ on Bug 1107355 so we can close this one as a dupe.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gmarty)
Resolution: --- → DUPLICATE
Duplicate of bug: 1107355
Flags: needinfo?(rmacdonald)
You need to log in before you can comment on or make changes to this bug.