If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

urls with multiple question marks go to wrong page (encodes first ? -> %3F)

VERIFIED DUPLICATE of bug 110671

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 110671
16 years ago
15 years ago

People

(Reporter: Steve Morrison, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
1. Go to the above url
2. Click on "map" next to the "A Touch-of-class Florist" listing.
3. The "map" url has two question marks in it, since it's passed through a
click-through counter script.  The url basically looks like this:
http://hostname/script.cgi?args&LOC=http://hostname/targetpage?name=args
after clicking on the link, this becomes:
http://hostname/script.cgi%3Fargs&LOC=http://hostname/targetpage?args
4. You get a page not found error because of the ? -> %3F encoding.

If you click on the "http://gtesupersite.com/touchofclass" link, it works,
because this link does not have a second "?" in the url.

*** This bug has been marked as a duplicate of 110671 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
VERIFIED: dupe of dupe, wrong behavior in URL escaping.
Status: RESOLVED → VERIFIED
Component: Networking: HTTP → Networking
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.