[Midori 2.0][Music player]The search result cannot match after tapping enter key again.

RESOLVED FIXED in Firefox OS v2.2

Status

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: hub, NeedInfo)

Tracking

unspecified
2.2 S5 (6feb)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [priority])

Attachments

(8 attachments)

(Reporter)

Description

4 years ago
FireFox OS V2.0
 
 mozilla build id:20141019000201
 
 DEFECT DESCRIPTION:
 The search result cannot match after tapping enter key again.
 
  REPRODUCING PROCEDURES:
 Pre-condition:MS has some songs;
 
 1.Launch music player;
 2.Slide down screen to search songs;
 3.Input some characters and then can see search results;
 4.Press Enter icon at the lower right corner of the keyboard,the keyboard is hidden and the search results can display;
 5.Again press Enter icon at the lower right corner of the keyboard,the word disappear in search box-->KO1;
 6.Again input some characters and tap enter key,the keyboard is hidden and the search results do not display-->KO2;
(Reporter)

Comment 1

4 years ago
Created attachment 8531449 [details]
PR824965_jrdlog
(Reporter)

Comment 2

4 years ago
Created attachment 8531450 [details]
issue_pic
(Reporter)

Comment 3

4 years ago
Mozilla ID : 1106970

Comment 4

4 years ago
[Blocking Requested - why for this release]:This pr blocked us, please help to fix it.
We hava a elastoplast solution but it will cause another pr.
blocking-b2g: --- → 2.0?
Flags: needinfo?(wehuang)
Hi, 
Is this bug reproducible in 1.3 SW?
Flags: needinfo?(sync-1)

Comment 6

4 years ago
It can reproduce on 1.3.
Our elastoplast solution is ignore enter key in search, but i don't think this a perfect solution.
Created attachment 8532402 [details]
video

we can reproduce on Flame v2.1 and v2.2, but the actual behavior in step 4 and 5 are different from reporter’s.
See attachment: video.MP4 & Flame2.1_logcat_1402.txt & Flame2.2_logcat_1414.txt
Reproducing rate: 0/5
Reproducing steps:
Pre-condition: MS has some songs;
1. Launch music player;
2. Slide down screen to search songs;
3. Input some characters and then can see search results;
4. Press Enter icon at the lower right corner of the keyboard.
** The keyboard is NOT hidden; the search results disappear and the word in search box disappear;
5. Again input some characters and tap enter key.
** The keyboard is NOT hidden and the search results do not display, after tap enter key, the word in search box disappear.

Flame2.1 build:
Gaia-Rev        5655269098c7e82254e56933f1af05b4abe2a2f3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86608c9389b5
Build-ID        20141204001201
Version         34.0

Flame2.2 build:
Gaia-Rev        984e6d79aa799d2695f9ca132dfdc1665a56c019
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a9fc46355661
Build-ID        20141204040202
Version         37.0a1
Created attachment 8532404 [details]
Flame2.1 logcat
Created attachment 8532405 [details]
Flame2.2  logcat
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected

Comment 10

4 years ago
[Blocking Requested - why for this release]:

[Triage] Indeed inconvenient to user but not a critical impact considering 2.0 timing, also not a regression. Nom. to 2.1 instead.
blocking-b2g: 2.0? → 2.1?
Flags: needinfo?(wehuang)

Comment 11

4 years ago
Dominic or Hub,

Can one of please take a look at this and see if we can fix in master (2.2)

Thanks
Hema
Assignee: nobody → dkuo
blocking-b2g: 2.1? → ---
Flags: needinfo?(hub)
Flags: needinfo?(dkuo)
Whiteboard: [priority]
Target Milestone: --- → 2.2 S4 (23jan)
(Assignee)

Comment 12

4 years ago
Dominic, if you are not actively working on this, I can take it.

Thanks
Flags: needinfo?(hub)
(Assignee)

Comment 13

4 years ago
I'll take it. This is just wrong.
Assignee: dkuo → hub
Status: NEW → ASSIGNED

Comment 14

4 years ago
(In reply to Hubert Figuiere [:hub] - on PTO 'til 2015 from comment #13)
> I'll take it. This is just wrong.

Thanks Hub, let me know if you have any question!
Flags: needinfo?(dkuo)
(Assignee)

Comment 15

4 years ago
Created attachment 8553798 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27636

This should fix the problem. Also in tile mode the keyboard was not the search one.
Attachment #8553798 - Flags: review?(dkuo)
(Assignee)

Comment 16

4 years ago
NOTE: I should write an integration test as well.
(Assignee)

Comment 17

4 years ago
Also one problem that remain is that we should have that bottom right key be neither "search" nor "return" but instead be "hide". At least with this patch it is search.
(Assignee)

Comment 18

4 years ago
(In reply to Hubert Figuiere [:hub] from comment #17)
> Also one problem that remain is that we should have that bottom right key be
> neither "search" nor "return" but instead be "hide". At least with this
> patch it is search.

Bug 1102481 will somewhat work around this.

Comment 19

4 years ago
Comment on attachment 8553798 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27636

Hub, after I tested this patch, I found after we entered some text then tap the enter/search key in the keyboard, though the keyboard will disappear but so does the search results, I think people should expect only dismiss the keyboard and keep the results, right? if so, then we might have to adjust this patch.
Attachment #8553798 - Flags: review?(dkuo)
(Assignee)

Comment 20

4 years ago
It has always been like that - just that before it made the search unusable again.

See also bug 1102481 comment 7 which should address your concern.
(Assignee)

Comment 21

4 years ago
Comment on attachment 8553798 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27636

Reworked the patch to actually disable the "enter" button. This make the behaviour consistent with search in Contacts, and this fixes the problem here too.
Attachment #8553798 - Flags: review?(dkuo)
(Assignee)

Updated

4 years ago
Blocks: 1102481

Comment 22

4 years ago
Comment on attachment 8553798 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27636

Looks good to me now, thanks Hub!(A suggestion in the github comments)
Attachment #8553798 - Flags: review?(dkuo) → review+
(Assignee)

Comment 23

4 years ago
Taken suggestion into account.

Merged
https://github.com/mozilla-b2g/gaia/commit/adb80fe7bc06abf7c79fb79e7c1a8f6ba79293ae
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 24

4 years ago
Comment on attachment 8553798 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27636

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no regression. This is 2.2+
[User impact] if declined: feature don't work properly. Didn't before anyway.
[Testing completed]: manual testing.
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none.
Attachment #8553798 - Flags: approval-gaia-v2.2?
(Assignee)

Updated

4 years ago
Attachment #8553798 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2?(bbajaj)
(In reply to Hubert Figuiere [:hub] from comment #24)
> Comment on attachment 8553798 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27636
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): no regression. This is 2.2+
> [User impact] if declined: feature don't work properly. Didn't before anyway.
> [Testing completed]: manual testing.
> [Risk to taking this patch] (and alternatives if risky): low
> [String changes made]: none.

Can we add unit/integration tests for this?
Flags: needinfo?(hub)
(Assignee)

Comment 26

4 years ago
Right now there is no integration test for this. And I don't think it is trivial, but I do have a Q1 goal to broaden the integration testing for the music app for 3.0. I can make sure this case is handled.
Flags: needinfo?(hub)
Comment on attachment 8553798 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27636

Requesting QA verification once this lands.
Attachment #8553798 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+

Updated

4 years ago
Keywords: verifyme
v2.2: https://github.com/mozilla-b2g/gaia/commit/262cd4df80bd0f4725e81c8a3a90758c07b47f29
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → fixed
Target Milestone: 2.2 S4 (23jan) → 2.2 S5 (6feb)

Comment 29

4 years ago
Created attachment 8558911 [details]
video.MP4

Hi Hubert,
I have verified this issue on Flame v2.2, and I found the keyboard doesnt's disappear after tapping "search" button at bottom right, and so does the search results. According your comment 17 and comment 21, I have a question, whether the current result is correct or not? I have uploaded the video, could you help to check it? Thanks!
See attachment:video.MP4

Flame 2.2 build:
Build ID               20150203002504
Gaia Revision          cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gaia Date              2015-02-03 00:56:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/11d93135c678
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.041704
Firmware Date          Tue Feb  3 04:17:15 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(hub)

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
(Assignee)

Comment 30

4 years ago
see comment 19, comment 20 and comment 21.

There is an upcoming fix with bug 1102481 to be close to the UX pattern used in contacts.
Flags: needinfo?(hub)

Comment 31

4 years ago
Created attachment 8569630 [details]
video.MP4

This issue has been verified successfully on Flame 2.2/3.0
When user types in a query that has no results, a message appeared in the space that shows results that says "No music found". When user taps the enter button, no action take place and the user is not taken out of the search flow.
See attachment:video.MP4
Rate:0/5

Flame 2.2 build:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150225010244
Gaia Revision          f6bfd854fe4746f21bc006eac145365e85f98808
Gaia Date              2015-02-24 21:10:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a8b3b67715a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.043702
Firmware Date          Wed Feb 25 04:37:14 EST 2015
Bootloader             L1TC00011880

Updated

4 years ago
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.