use nginx+uwsgi for Socorro apps

RESOLVED FIXED

Status

Socorro
Infra
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rhelmer, Assigned: rhelmer)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
Right now we use Apache+mod_wsgi, we could save a lot of memory and serve more requests per instance if we switch to nginx+uwsgi instead.
Blocks: 1136225
(Assignee)

Updated

3 years ago
Assignee: nobody → rhelmer
Blocks: 1123833
No longer blocks: 1097891
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
PR: https://github.com/mozilla/socorro-infra/pull/37
(Assignee)

Comment 2

3 years ago
phrawzty we need to drop nginx config fragments (into /etc/nginx/conf.d/), this will point nginx at the correct uwsgi socket for this service.

It seems like the right place for that is in the role, when nodes get provisioned by the ASG.

Does that sound reasonable, and should we specify the vhost (crash-stats.mozilla.com, crash-reports.mozilla.com) in these files too?
Flags: needinfo?(dmaher)
(In reply to Robert Helmer [:rhelmer] from comment #2)
> phrawzty we need to drop nginx config fragments (into /etc/nginx/conf.d/),
> this will point nginx at the correct uwsgi socket for this service.
> 
> It seems like the right place for that is in the role, when nodes get
> provisioned by the ASG.

Yep, that's definitely something for the provision phase, which means it fits in the role nicely.  (Look at us making up best practices!)

> Does that sound reasonable, and should we specify the vhost
> (crash-stats.mozilla.com, crash-reports.mozilla.com) in these files too?

Sound the warning alarms! Hardcoded hostnames are a bad smell, which isn't to say that it's always wrong to do so, but it your default reaction should be scepticism. :)  A better approach would be templates (it's Puppet after all) that pull these from the Source of Truth.
Flags: needinfo?(dmaher)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1145489

Comment 5

3 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/a7d1638ce539280168db0cc0c4e3bd374b7aa84e
fix bug 1106992 - use nginx+uwsgi

https://github.com/mozilla/socorro/commit/e3b20778d03831dc932e9900a7aef38f22f409cb
Merge pull request #2685 from rhelmer/centos7-fpm-update

fixes bug 1106992, 1145487, 1146984 - Centos7 major packaging / infra update

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.