[W] MLK: Memory leak of 174 bytes from 1 block allocated in JS_malloc

RESOLVED DUPLICATE of bug 102655

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 102655
16 years ago
16 years ago

People

(Reporter: Navin Gupta, Assigned: dbaron)

Tracking

({mlk})

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
malloc         [msvcrt.DLL]
            JS_malloc      [jsapi.c:1411]
            fun_xdrObject  [jsfun.c:1204]
            js_XDRObject   [jsobj.c:3452]
            JS_XDRValue    [jsxdrapi.c:542]
            XDRAtomListElement [jsscript.c:268]
            XDRAtomMap     [jsscript.c:303]
            js_XDRScript   [jsscript.c:411]
            JS_XDRScript   [jsxdrapi.c:579]
            nsXULPrototypeScript::Deserialize(nsIObjectInputStream 
*,nsIScriptContext *) [nsXULElement.cpp:4998]
            XULContentSinkImpl::OpenScript(nsIParserNode const&) 
[nsXULContentSink.cpp:1645]
            XULContentSinkImpl::OpenTag(nsIParserNode const&,nsINodeInfo *) 
[nsXULContentSink.cpp:1468]
            XULContentSinkImpl::OpenContainer(nsIParserNode const&) 
[nsXULContentSink.cpp:634]
            CWellFormedDTD::HandleStartToken(CToken *) [nsWellFormedDTD.cpp:649]
            CWellFormedDTD::HandleToken(CToken *,nsIParser *) 
[nsWellFormedDTD.cpp:522]
            nsParser::BuildModel(void) [nsParser.cpp:1979]
            nsParser::ResumeParse(int,int) [nsParser.cpp:1845]
            nsParser::ContinueParsing(void) [nsParser.cpp:1497]
            CSSLoaderImpl::Cleanup(URLKey&,SheetLoadData *) 
[nsCSSLoader.cpp:776]
            CSSLoaderImpl::SheetComplete(nsICSSStyleSheet *,SheetLoadData *) 
[nsCSSLoader.cpp:886]
(Reporter)

Comment 1

16 years ago
We need to fix this leak. It shows up too many times in the purify log 
generated for some pop3 operations. 
(Reporter)

Updated

16 years ago
Keywords: mailtrack, mlk, nsbeta1
It's probably happening because you're leaking some higher-level JS object
(e.g., a GlobalWindowImpl) that's causing all this other stuff to leak.

Could you give steps to reproduce?
Component: Style System → XP Toolkit/Widgets
s/JS object/JS root/
(Reporter)

Comment 4

16 years ago
steps

1) Log into a pop3 mail acct.
2) Select 5 messages in a folder and delete them
3) exit

I don't see globalWindowImpl leaking, will attach bloat/leak log. 
(Reporter)

Comment 5

16 years ago
Created attachment 58392 [details]
bloat/leak log
I see an nsXULPDGlobalObject leaking.
Are there simpler steps to reproduce?  I don't have access to a POP mail account.
(Reporter)

Comment 8

16 years ago
If you want I can send you the details for a pop test account. 
Er, actually, was this on Windows?
(Reporter)

Comment 10

16 years ago
yes

*** This bug has been marked as a duplicate of 102655 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.