Closed Bug 1107045 Opened 6 years ago Closed 6 years ago

Need to register resource testing-common to import fakeserver modules in mailnews from mozmill

Categories

(Thunderbird :: Testing Infrastructure, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 904812

People

(Reporter: hiro, Assigned: hiro)

Details

Attachments

(1 file)

Unfortunately nsIEditor can not be implemented in JS anymore so we have to write mozmill test to test some functions in mailnews/composition instead of writing xpcshell test.

But to write mozmill tests for those functions needs to smtpd.js at least.
Attached patch proposed patchSplinter Review
With this patch we can import smtpd.js using testing-common-resource-helper in this patch.

https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=b41b13d7b7e3
Assignee: nobody → hiikezoe
Summary: Need to register resource testing-common to import fakeserver modules in mailnews → Need to register resource testing-common to import fakeserver modules in mailnews from mozmill
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904812
You need to log in before you can comment on or make changes to this bug.