Window menu is empty when opened from restored windows

RESOLVED DUPLICATE of bug 1107094

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 1107094
3 years ago
3 years ago

People

(Reporter: gary.kupczak, Unassigned)

Tracking

34 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8531630 [details]
Firefox 34 Empty Window Menu.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

1. Launch Firefox after crash.
2. Click on the Window menu from any restored window.


Actual results:

No windows are listed in the menu, just the system Minimize and Zoom commands.


Expected results:

Windows should be listed in the menu.
(Reporter)

Updated

3 years ago
Component: Untriaged → Menus

Comment 1

3 years ago
¡Hola Gary!

Sorry to hear Firefox is giving you problems.

Could you please go to about:crashes and paste the contents of the page on this bug?

¡Gracias!
Alex
Flags: needinfo?(gary.kupczak)
(Reporter)

Comment 2

3 years ago
Hi Alex. Here's my about:crashes:

Submitted Crash Reports
Report ID 	Date Submitted
bp-08d4f0f3-2e45-47c4-ae79-d38282141203	12/3/14	11:13 AM
bp-3de3eb32-8a46-4c25-8438-2683a2141118	11/18/14	2:59 PM
8FA1CC78-5B05-4628-8724-888E24FACC2D	11/13/14	10:54 AM
bp-0e3a9584-278c-416c-a78e-811112141110	11/10/14	10:59 AM
5A3324C2-29A9-48EE-9073-AFBF745BC773	11/7/14	10:13 AM
bp-577a72e2-a835-435c-9da1-a344b2141106	11/6/14	10:38 AM
bp-5332e0dc-cc16-4a22-926e-1659d2141106	11/6/14	9:59 AM
bp-827eb6db-f46b-47bb-ae20-7daa62141106	11/6/14	1:01 AM
52C32DB7-2B31-4EBA-A300-FA2AAD01F0B5	11/4/14	4:14 PM
101336E4-BCFC-4FCB-A3D8-F56E521AE481	11/4/14	12:02 PM
bp-4dad8a10-f52c-41c8-8f5b-cd2962141028	10/28/14	2:13 PM
B7BB3913-36CC-4A43-A3D8-0A84AE5F0CFD	10/27/14	9:05 AM
F1FCBCA9-8A6B-4A9F-86D7-386ACCDC9840	10/22/14	4:53 PM
685E617D-9CFF-4955-9308-58B242606C5A	10/21/14	4:25 PM
bp-a96c96ac-6acb-41e2-9096-a5e702140923	9/23/14	12:29 PM
bp-6e07011c-c514-475b-827e-ec5032140923	9/23/14	9:56 AM
22EF64D7-16FD-4AFD-9269-9AED3CDE7FBA	9/22/14	12:23 PM
bp-4ac48617-7655-4bf6-972c-e37652140918	9/18/14	3:35 PM
bp-722e7213-b8cb-49fc-93c8-783312140916	9/16/14	4:25 PM
EE4C6F85-45B2-48BE-8CCC-07DA852AAD51	9/16/14	2:31 PM
bp-55cad2af-ec3a-4725-8661-ac0482140915	9/15/14	9:35 AM
bp-3bb30c20-e145-4f1e-b523-37c932140915	9/15/14	9:11 AM
bp-230e41bb-5117-4c4e-9016-e2c242140912	9/12/14	3:51 PM
CC71500F-C68C-4417-A5A5-7F803DBF5516	9/11/14	3:58 PM
bp-cd290138-eaed-4ea6-bb6c-f60f12140911	9/11/14	2:36 PM
bp-03155089-7d04-4718-be7e-88a8a2140828	8/28/14	4:19 PM
A1BE4B4A-E328-4EA8-BA63-525311BEA77D	8/28/14	3:12 PM
bp-d5c5a696-58d4-4885-b38c-785752140828	8/28/14	8:57 AM
7DADE943-5D63-4DC4-8466-33BB21896540	8/27/14	12:04 PM
34F83806-DB8D-4CE8-8EA6-D39236F6FC38	8/27/14	9:51 AM
35E2DC1E-C868-4249-A398-C6668DA029F0	8/26/14	2:32 PM
776DD1E7-F9FA-4545-950A-A95DFE23DC22	8/25/14	9:22 AM
bp-a982724b-bc86-49a4-bf1e-94bbd2140822	8/22/14	10:44 AM
bp-63ae63d3-0dc6-41f6-81a5-88c402140821	8/21/14	10:06 AM
bp-48e2fad0-5e80-461c-abc0-a28872140820	8/20/14	9:59 AM
BD3EF79B-D3EB-4DCA-8013-D7D5AD3E7FAF	8/15/14	1:34 PM
E37ED9A3-38F7-4E63-A29F-2B597F474449	8/15/14	11:14 AM
bp-46821f7e-9e5c-4f54-8580-74a5f2140815	8/15/14	10:08 AM
383BAAD6-06A3-4BA7-9EC3-3DB1473542BE	8/14/14	9:37 AM
bp-1d0cf077-c77e-4bdc-8122-e416a2140813	8/13/14	2:33 PM
bp-eb36c59f-6344-4efb-baa8-82df22140813	8/13/14	11:01 AM
0172813A-6C64-4A32-8728-B08BADDC47FB	8/13/14	9:47 AM
F7624611-2192-4194-BC05-21E93A1F194D	8/13/14	9:28 AM
bp-ab2de6c5-848b-446d-b57a-1e5ef2140812	8/12/14	11:01 AM
bp-767b0e4f-9379-4b80-bdcc-617ec2140812	8/12/14	9:56 AM
bp-5babeed7-bf17-4e50-ad9b-831692140808	8/8/14	2:57 PM
87A2C0A0-CAA6-4C55-A419-7105E1A8DE03	8/8/14	10:49 AM
bp-c3bce3b4-0476-49d7-90ef-6a2112140806	8/6/14	2:41 PM
bp-0be02682-ebe2-45f8-9546-9b4092140804	8/4/14	2:18 PM
C669B87B-1464-48FD-9512-F85C82B5B3D4	8/4/14	10:12 AM
bp-b50809c3-6843-4d77-a665-5c76c2140801	8/1/14	5:14 PM
bp-b4bff938-433f-48c5-a72c-1f8bf2140801	8/1/14	2:41 PM
A2583730-8356-4055-A8D3-F29977189164	8/1/14	10:52 AM
bp-d16acc3b-a1f1-43dd-aed4-281d02140731	7/31/14	12:39 PM
bp-f1d84e60-bc18-44a1-ab00-bc7232140731	7/31/14	12:35 PM
E6E2D741-248C-4F3B-828E-E75D942392FF	7/29/14	9:51 AM
DB4C6766-9A9D-4C72-8A26-8C9162C0C272	7/25/14	9:30 AM
bp-aaf4217e-e1c4-4afb-9454-4c0ed2140723	7/23/14	9:56 AM
bp-c8b627b7-5173-4a50-a126-831962140722	7/22/14	3:05 PM
AFFCC96A-9A5F-4AC8-B3BF-3B1E07FD07B7	7/18/14	9:06 AM
2871F60E-1BA0-4F59-8FA5-2E2859FB8D0E	7/15/14	10:47 AM
bp-451e7822-366f-48be-b375-49cc92140710	7/10/14	3:57 PM
bp-4b05e6a4-f56e-4636-a6bc-f3f662140710	7/10/14	9:56 AM
bp-8e789fcc-d255-402a-98a7-4b9942140702	7/2/14	9:17 AM
bp-b9ee7960-3a86-49e7-965e-b22682140624	6/24/14	12:42 PM
bp-f9f281d4-8b08-4c47-b29e-7d7572140619	6/19/14	3:48 PM
bp-b615f726-b2c3-4e0e-b6ba-926092140617	6/17/14	2:57 PM
bp-0c3099d6-a296-4d15-82af-6f7862140613	6/13/14	12:18 PM
bp-76848944-b691-4a94-a892-ad2072140611	6/11/14	12:26 PM
bp-5e94ccf0-20b2-4e81-9db9-9a5252140314	3/14/14	3:57 PM
bp-0d17e700-6e69-4389-a224-b53542140304	3/4/14	5:56 PM
bp-09571ee1-4b9d-4b45-b82b-484132140304	3/4/14	4:19 PM
bp-bb77c3a8-e7af-491c-95ad-a1ce02140304	3/4/14	3:31 PM
bp-a27194e5-ac58-4e90-a259-6a17a2140228	2/28/14	10:08 AM
bp-23a9a46b-9dc7-4870-bbf9-0ebbe2140206	2/6/14	3:13 PM
bp-3d57eeac-a488-4c84-9cec-8f0a12140206	2/6/14	1:56 PM
bp-4833e6e3-a3d2-448b-94fb-7606c2140206	2/6/14	12:23 PM
bp-33d91cba-de70-4879-aaaa-964c42140206	2/6/14	12:17 PM
bp-c53ec8e9-9071-4c42-8c71-5a9672140206	2/6/14	11:49 AM
bp-5b6af745-896b-4a66-a28d-ac1a52140206	2/6/14	11:36 AM
bp-701ca6f2-4ca6-4b5c-af1c-ca3b62140205	2/5/14	11:50 AM
bp-456c0c2d-3f16-486a-9a3e-fdb0b2140114	1/13/14	6:00 PM
bp-9a756383-8813-46da-a9a4-2d6712140108	1/8/14	11:46 AM
bp-0c0b5136-df31-4372-b2ab-be46a2140108	1/8/14	10:53 AM
bp-4bef9a7f-6f7b-40a3-8254-b79ca2140108	1/8/14	9:55 AM
bp-030938d7-4c03-4a5d-835e-2062e2140103	1/3/14	2:54 PM
bp-54faec00-9f71-48a5-8724-12f962140103	1/3/14	2:52 PM
bp-305338a9-d038-4314-a288-56eae2131224	12/24/13	11:25 AM
bp-18a5282f-8ac9-4b17-a7b0-4a1182131224	12/24/13	10:17 AM
bp-e07a6f1f-9925-4fc5-a0b5-8cd182131224	12/24/13	10:09 AM
bp-29468f19-285d-4b3f-8d85-a94a22131224	12/24/13	9:50 AM
bp-152a74d4-92dd-4f20-831e-44c1c2131223	12/23/13	2:48 PM
bp-961258be-d175-47e5-a175-6a0fd2131218	12/18/13	12:36 PM
bp-d1c2e785-6feb-4dd6-890c-c0e2b2131218	12/18/13	12:27 PM
bp-06f0d048-cbfa-4fb6-8e43-525c52131218	12/18/13	12:21 PM
bp-c49bd55e-004e-4cc1-8bf1-0707d2131217	12/17/13	4:43 PM
A42CF83A-0E43-4676-A05C-5FD50D64BD9E	12/4/13	10:13 PM
bp-3121112f-27bc-490d-bd28-7555c2131105	11/5/13	4:39 PM
0F5EBFAA-FA4E-4791-B4DE-433C486E23C9	11/4/13	3:22 PM
bp-9d05f8e9-7908-45e5-a2af-670bc2131003	10/3/13	1:04 PM
bp-6530eaa5-759b-41bc-9cff-b4b732130501	5/1/13	2:30 PM
DFAF52D8-2241-4600-82D8-0059C3C1482F	4/11/13	10:19 AM
Flags: needinfo?(gary.kupczak)

Comment 3

3 years ago
¡Hola Gary!

Thanks for providing the requested info.

From the report I see your Firefox is still 33.1.1 which is old.

Make sure to update your Firefox as 34 is now out, see https://support.mozilla.org/en-US/kb/update-firefox-latest-version

If your problem is solved. Please go to https://bugzilla.mozilla.org/show_bug.cgi?id=1107125 and change the "Status" towards the bottom to RESOLVED WORKSFORME.

¡Gracias!
Flags: needinfo?(gary.kupczak)
(Reporter)

Comment 4

3 years ago
Hi Alex,

I was on 33.1.1 when the crash happened, but after I relaunched I had been updated to 34, so I was on the latest version when I observed the problem.
Flags: needinfo?(gary.kupczak)

Comment 5

3 years ago
Do you have multiple Firefox windows open?

If not, it is expected that nothing shows there I'd think.

"The menu bar menus will change as you switch applications. For example, when the Finder is active, you'll see the following menus across the menu bar: the Apple logo, Finder, File, Edit, View, Go, Window, and Help. When you click the Window menu, its menu displays the following menu items: Minimize, Zoom, Cycle Through Windows, and Bring All to Front. (Depending on whether or not you have any Finder windows open, your Window menu may contain a few more items.)" http://support.apple.com/en-us/HT2473
Flags: needinfo?(gary.kupczak)
(Reporter)

Comment 6

3 years ago
Yes, I have multiple windows open. But even when only one window is open, it is still typically listed in the Window menu.

From my observations, the problem only seems to occur on windows restored after a crash. If I open a new window in the same session, the problem is not observed for that window only.
Flags: needinfo?(gary.kupczak)

Comment 7

3 years ago
Could you attach a screen capture of the non-crashed instance?

Does the problem appear with Nightly from https://nightly.mozilla.org/ as well?
Flags: needinfo?(gary.kupczak)
(Reporter)

Comment 8

3 years ago
I've had a couple of crashes since reporting the problem and I'm no longer able to reproduce it. Either it was a fluke, or a product of the very specific circumstances at the time it happened (a crash after the 34 update had been downloaded but before I had restarted the browser).

Thanks for the assistance! It's probably fine to resolve this unless you feel that particular edge case is worth looking into.
Flags: needinfo?(gary.kupczak)
Uhm, the bug was originally filed about the window menu, and not about the crashes, right? In any case, we also have bug 1107094 and bug 1107112 about the same bug which mention that the problem happens on 10.10 and 10.7, respectively, so at least we now know that it doesn't depend on the OS version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107094
(Reporter)

Comment 10

3 years ago
Yes, the issue was originally filed about the Window menu, but on further observation it appeared to be occurring only after recovering from a crash.
Oh I see, I didn't catch that.
You need to log in before you can comment on or make changes to this bug.