If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Airplane Mode] Cannot make an Emergency Call during Airplane Mode

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0M unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-1], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8531667 [details]
logcat_20141203_1132.txt

Description:
While Airplane Mode is enabled the user is unable to make an emergency phone call. (such as 911 or 112)

Repro Steps:
1) Update a Flame to 20141203040207
2) Enable Airplane Mode
3) From Dialer make an outgoing call from an emergency number such 911 or 112.
4) Observe Device behaviour.

Actual:
After dialing phone number UI will change to a "Connecting" screen. Clicking can be heard from the ear piece. Airplane mode becomes disabled but no outgoing call is established.

Expected:
It is expected that the user will be able to make a call to an Emergency phone number such as 911 or 112.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141203040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/8567/
See attached: Logcat & Video
Youtube: http://youtu.be/lu8BEyCZZ-I
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
This issue also occurs on the Flame 2.1 KK (319mb).
Result: User is unable to make an Emergency call by dialing 112 while airplane mode is activated.

Flame 2.1 Full

Device: Flame 2.1 (319mb)(KitKat)(Full Flash)
Build ID: 20141203001205
Gaia: dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko: ebce587d2194
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

----------------------------------------------------------------------------

This issue does NOT occur on the Flame 2.0 KK (319mb)
Result: User IS able to make an Emergency call by dialing 112 while airplane mode is activated.

Flame 2.0 Full

Device: Flame 2.0 (319mb)(KitKat)(Full Flash)
Build ID: 20141203000201
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: 29222e215db8
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Adding qawanted for reproducibility. If you guys get this consistently let's get a regression window here.
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawanted
Flags: needinfo?(dharris) → needinfo?
Flags: needinfo?
We have to determined that this issue was caused by a faulty phone so closing this worksforme.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.