[SIM Lock] No prompt for PIN when locked SIM is inserted in slot 2

VERIFIED FIXED in 2.2 S2 (19dec)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rmead, Assigned: mancas)

Tracking

({regression})

unspecified
2.2 S2 (19dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-flame-reduced-run], )

Attachments

(2 attachments)

Reporter

Description

5 years ago
Posted file Flame2.2logcat.txt
Description:
When a locked SIM is inserted into slot 2 of the Flame device, the user is never prompted to insert a PIN after the device has booted.

Prereq:
Have a locked SIM inserted in slot 2

Repro Steps:
1) Update a Flame to 20141203040207
2) Boot phone and unlock screen


Actual:
You are brought to homescreen and never prompted for the SIM PIN


Expected:
After unlocking the screen, the SIM PIN screen should prompt.


Flame 2.2(319mb)(KitKat)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
Build ID: 20141203040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency: 100%
See attached: logcat, video - http://youtu.be/G5bIGUZh8eM
Reporter

Comment 1

5 years ago
This issue does NOT happen on Flame 2.0 and Flame 2.1

If a locked SIM card is inserted into slot 2, when the device is started, you will get a SIM prompt once you unlock the screen.

Flame 2.0 Full

Device: Flame 2.0 (319mb)(KitKat)(Full Flash)
Build ID: 20141203000201
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: 29222e215db8
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 2.1 Full

Device: Flame 2.1 (319mb)(KitKat)(Full Flash)
Build ID: 20141203001205
Gaia: dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko: ebce587d2194
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Nominating 2.2? this is a regression and the user should always be asked to input a PIN when it is active on the SIM.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: ckreinbring
Flags: needinfo?(dharris) → needinfo?
Regression window
Last working
BuildID: 20141127164243
Gaia: 80bc1445959db79e9d2e947cc56e1eb7b0d3d0f0
Gecko: 1d1cbbd46b0d
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141127170944
Gaia: 1fff49c664f905f11a86426a9835e6df6b58e825
Gecko: ebdbd84d933d
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 80bc1445959db79e9d2e947cc56e1eb7b0d3d0f0
Gecko: ebdbd84d933d
Broken Gaia / Working Gecko = Repro
Gaia: 1fff49c664f905f11a86426a9835e6df6b58e825
Gecko: 1d1cbbd46b0d
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/80bc1445959db79e9d2e947cc56e1eb7b0d3d0f0...1fff49c664f905f11a86426a9835e6df6b58e825


B2G Inbound
Last working
BuildID: 20141127032201
Gaia: 05d9637fb89c4d2d36f467559aa1959450e0ffad
Gecko: 28f66e00fa3e
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141127041202
Gaia: 874575b01cb7d7c9d79400406df4c499e59eac9f
Gecko: 20484aaa49cf
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 05d9637fb89c4d2d36f467559aa1959450e0ffad
Gecko: 20484aaa49cf
Broken Gaia / Working Gecko = Repro
Gaia: 874575b01cb7d7c9d79400406df4c499e59eac9f
Gecko: 28f66e00fa3e
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/05d9637fb89c4d2d36f467559aa1959450e0ffad...874575b01cb7d7c9d79400406df4c499e59eac9f
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by patch for Bug 1102965  - can you take a look Alberto
Blocks: 1102965
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Flags: needinfo?(apastor)
Flags: needinfo?
QA Contact: ckreinbring
Assignee

Updated

5 years ago
Assignee: nobody → b.mcb
Assignee

Comment 5

5 years ago
Posted file Proposed patch
Hey Alberto, I took this bug, hope you don't mind. We just need to check if there is more than one SIM inserted to cover cases like this one.

Thanks
Attachment #8532410 - Flags: review?(alive)
Attachment #8532410 - Flags: feedback?(apastor)
Comment on attachment 8532410 [details] [review]
Proposed patch

LGTM, thanks
Attachment #8532410 - Flags: review?(alive) → review+
Comment on attachment 8532410 [details] [review]
Proposed patch

LGTM, thanks!
Flags: needinfo?(apastor)
Attachment #8532410 - Flags: feedback?(apastor) → feedback+
Assignee

Updated

5 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/f2b9813ad5bb46f50e26c0a1bd25f7a6eae5144c
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S2 (19dec)
2.2+ all fixed regressions -- reset if disagree.
blocking-b2g: 2.2? → 2.2+

Comment 10

5 years ago
Verified the issue is fixed on Flame 2.2

Prompt SIM appears every time when the SIM card is inserted in the second slot 

"Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141216040205
Gaia: af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko: a3030140d5df
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.