Closed Bug 1107280 Opened 5 years ago Closed 5 years ago

Reftest failures on B2G emulator with event-regions enabled

Categories

(Core :: Layout, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: kats, Assigned: kats)

References

Details

I landed bug 928833 [1] but it was backed out for test failures. There were a set of reftests that failed consistently on B2G:

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/async-scrolling/bg-fixed-cover-3.html | image comparison (==), max difference: 255, number of differing pixels: 51200

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/async-scrolling/position-fixed-cover-3.html | image comparison (==), max difference: 128, number of differing pixels: 50000

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/async-scrolling/bg-fixed-cover-3.html | image comparison (==), max difference: 255, number of differing pixels: 51200

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/async-scrolling/position-fixed-cover-3.html | image comparison (==), max difference: 128, number of differing pixels: 50000

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/async-scrolling/checkerboard-2.html | image comparison (==), max difference: 255, number of differing pixels: 49900

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/async-scrolling/checkerboard-3.html | image comparison (==), max difference: 128, number of differing pixels: 49900

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/backgrounds/background-repeat-large-area.html | image comparison (==), max difference: 239, number of differing pixels: 800000 

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/bugs/1081185-1.html | image comparison (==), max difference: 128, number of differing pixels: 75

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/css-gradients/large-gradient-1.html | image comparison (==), max difference: 214, number of differing pixels: 800000

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/css-gradients/large-gradient-2.html | image comparison (==), max difference: 255, number of differing pixels: 800000

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/css-gradients/large-gradient-3.html | image comparison (==), max difference: 211, number of differing pixels: 800000

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/css-gradients/large-gradient-4.html | image comparison (==), max difference: 255, number of differing pixels: 800000 

REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/scrolling/scroll-behavior-6.html | image comparison (==), max difference: 255, number of differing pixels: 100

These need to be addressed before we can reland event-regions on B2G.

[1] https://treeherder.mozilla.org/ui/#/jobs?repo=b2g-inbound&revision=a686c6909b22
Assignee: nobody → bugmail.mozilla
The patch on bug 1107404 fixes some of these (all the async-scrolling/ ones). Try push with that patch is at https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=3c9e5cf45004
Bug 1107606 should fix the scroll-behavior-6 test. Still need to figure out the rest of them. The try push at https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=7c8128150c08 has display-list dumps for the 1081185-1.html failure (in the logs for R20) that should help figure out what's going on there.
I split out the 1081185-1.html failure into bug 1107843. After that the remaining 5 failures are all very similar, and involve a tall page that gets scrolled down and then drawWindow'd. The problem here seems to be that after the scroll down happens, the after-paint event contains a clientRect that's 100000 pixels tall which is too tall for drawWindow. drawWindow therefore bails out and only the initial canvas rendering is used. This causes the test to fail.
I fuzzed the last remaining test (covered by bug 1107843) after a discussion with tn on IRC, since the failure is unrelated to event regions. I'm leaving bug 1107843 open to track down the root cause, but this fuzz effectively fixes this bug.

https://hg.mozilla.org/integration/mozilla-inbound/rev/8ccf2511fe61
https://hg.mozilla.org/mozilla-central/rev/8ccf2511fe61
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.