Bug 1107294 (gonk-L-Wifi)

[meta] Wifi Android L Porting

RESOLVED FIXED in 2.2 S4 (23jan)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: askeing, Assigned: vchang)

Tracking

unspecified
2.2 S4 (23jan)
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+)

Details

Reporter

Description

5 years ago
No description provided.
Reporter

Comment 1

5 years ago
Porting Wifi module to support lollipop release
Reporter

Comment 2

5 years ago
Cannot detect the Wifi AP now
Vincent, please check this. Thanks.
Assignee: nobody → vchang

Comment 4

5 years ago
Logs between kk and L builds looked fairly similar up until this point:

on kk build, I see in the log:

7458:D/wpa_supplicant( 1107): nl80211: Connect event
7459:D/wpa_supplicant( 1107): nl80211: Associated on 2437 MHz
7460:D/wpa_supplicant( 1107): nl80211: Associated with 00:0b:86:7c:1d:30
7461:D/wpa_supplicant( 1107): nl80211: Operating frequency for the associated BSS from scan results: 2437 MHz
7463:D/wpa_supplicant( 1107): wlan0: Event ASSOC (0) received
7464:D/wpa_supplicant( 1107): wlan0: Association info event
7465:D/wpa_supplicant( 1107): wlan0: freq=2437 MHz
7466:D/wpa_supplicant( 1107): FT: Stored MDIE and FTIE from (Re)Association Response - hexdump(len=0):
7467:D/wpa_supplicant( 1107): wlan0: State: ASSOCIATING -> ASSOCIATED

whereas on L build I see:

2683:D/wpa_supplicant( 1023): nl80211: Connect event
2684:D/wpa_supplicant( 1023): wlan0: Event ASSOC_REJECT (13) received
2685:I/wpa_supplicant( 1023): wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:0b:86:7c:18:40 status_code=1
2686:D/wpa_supplicant( 1023): CTRL_IFACE monitor send - hexdump(len=39): 2f 64 61 74 61 2f 6d 69 73 63 2f 77 69 66 69 2f 73 6f 63 6b 65 74 73 2f 77 70 61 5f 63 74 72 6c ...
2687:D/wpa_supplicant( 1023): Added BSSID 00:0b:86:7c:18:40 into blacklist
2688:D/wpa_supplicant( 1023): wlan0: Blacklist count 1 --> request scan in 100 ms
2689:D/wpa_supplicant( 1023): wlan0: Setting scan request: 0 sec 100000 usec
2690:D/wpa_supplicant( 1023): wlan0: P2P: Station mode scan operation not pending anymore (sta_scan_pending=0 p2p_cb_on_scan_complete=0)
2691:D/wpa_supplicant( 1023): wlan0: State: ASSOCIATING -> DISCONNECTED

If needed, I can reproduce this and collect full logs, but I don't have them right now.

Updated

5 years ago
blocking-b2g: --- → 2.2?

Comment 5

5 years ago
To use feature b2g instead of blocking flag
blocking-b2g: 2.2? → ---
feature-b2g: --- → 2.2+
Component: General → Wifi
QA Whiteboard: [2.2-feature-qa+]
Depends on: 1104664
QA Whiteboard: [2.2-feature-qa+] → [2.2-feature-qa+][COM=Wifi]
Depends on: 1113535
(In reply to Greg Grisco from comment #4)
> Logs between kk and L builds looked fairly similar up until this point:
> 
> on kk build, I see in the log:
> 
> 7458:D/wpa_supplicant( 1107): nl80211: Connect event
> 7459:D/wpa_supplicant( 1107): nl80211: Associated on 2437 MHz
> 7460:D/wpa_supplicant( 1107): nl80211: Associated with 00:0b:86:7c:1d:30
> 7461:D/wpa_supplicant( 1107): nl80211: Operating frequency for the
> associated BSS from scan results: 2437 MHz
> 7463:D/wpa_supplicant( 1107): wlan0: Event ASSOC (0) received
> 7464:D/wpa_supplicant( 1107): wlan0: Association info event
> 7465:D/wpa_supplicant( 1107): wlan0: freq=2437 MHz
> 7466:D/wpa_supplicant( 1107): FT: Stored MDIE and FTIE from (Re)Association
> Response - hexdump(len=0):
> 7467:D/wpa_supplicant( 1107): wlan0: State: ASSOCIATING -> ASSOCIATED
> 
> whereas on L build I see:
> 
> 2683:D/wpa_supplicant( 1023): nl80211: Connect event
> 2684:D/wpa_supplicant( 1023): wlan0: Event ASSOC_REJECT (13) received
> 2685:I/wpa_supplicant( 1023): wlan0: CTRL-EVENT-ASSOC-REJECT
> bssid=00:0b:86:7c:18:40 status_code=1
> 2686:D/wpa_supplicant( 1023): CTRL_IFACE monitor send - hexdump(len=39): 2f
> 64 61 74 61 2f 6d 69 73 63 2f 77 69 66 69 2f 73 6f 63 6b 65 74 73 2f 77 70
> 61 5f 63 74 72 6c ...
> 2687:D/wpa_supplicant( 1023): Added BSSID 00:0b:86:7c:18:40 into blacklist
> 2688:D/wpa_supplicant( 1023): wlan0: Blacklist count 1 --> request scan in
> 100 ms
> 2689:D/wpa_supplicant( 1023): wlan0: Setting scan request: 0 sec 100000 usec
> 2690:D/wpa_supplicant( 1023): wlan0: P2P: Station mode scan operation not
> pending anymore (sta_scan_pending=0 p2p_cb_on_scan_complete=0)
> 2691:D/wpa_supplicant( 1023): wlan0: State: ASSOCIATING -> DISCONNECTED
> 
> If needed, I can reproduce this and collect full logs, but I don't have them
> right now.

The reason you saw the wifi is disconnected is because dhcp client is not implemented in Android L version which is bug 1113535. After bug 1113535 is fixed, we still need the bug 1104664 to set the route rules when network is up in networkManager.

Updated

5 years ago
Status: NEW → ASSIGNED

Updated

5 years ago
Target Milestone: --- → 2.2 S3 (9jan)
No longer blocks: 1116434
No longer blocks: 1116438

Comment 7

5 years ago
wifi can turn on now, but need bug 1104664 to set the route rules and connection.
Target Milestone: 2.2 S3 (9jan) → 2.2 S4 (23jan)
Depends on: 1116434
Depends on: 1116438

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.