Bug 1107301 (gonk-L-Audio)

[meta] Audio/Video Android L Porting

RESOLVED DUPLICATE of bug 1112312

Status

defect
RESOLVED DUPLICATE of bug 1112312
5 years ago
5 years ago

People

(Reporter: askeing, Assigned: rlin)

Tracking

unspecified
2.2 S3 (9jan)
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+)

Details

Attachments

(2 attachments)

No description provided.
Porting Audio module to support lollipop release
Askeing, please provide the failure symptom.
Flags: needinfo?(fyen)
We cannot test audio SW/HW decoding due to the storage doesn't work now.
After bug 1107291 fixed, then we can test it.
Depends on: gonk-L-Storage
Flags: needinfo?(fyen)
blocking-b2g: --- → 2.2?
feature-b2g: --- → 2.2+
QA Whiteboard: [2.2-feature-qa+]
Randy, can you help this bug? Thanks.
Assignee: nobody → rlin
I found:
1. Device miss the libOpenSLES.so and related library
2. System call 266 was blocked by sandbox. (Or more) 
==>seccomp sandbox violation: pid 3455, syscall 266, args 2942045370 88 3198033376 0 4294967180 3198033376.  Killing process

After disabling sandbox and push android n5 /system/lib/* into device with FxOS. 
We can hear dtmf tone /ringtone from device.
OMX Decoder was disabled. So that MP3 can't play.
Hi Michael, I remove the dependency of libandroid_runtime, could you help to review this? 

And there is one more modify about gecko SandboxFilter, then it has sound in Android L.
Attachment #8538977 - Flags: review?(mwu)
Hi Jed, please help to review this modification. thanks
Attachment #8539005 - Flags: review?(jld)
What are these patches for? Audio seems to work fine for me. We don't build libstagefright_http_support.

./config.sh nexus-5-l and apply the patches from bug 1102266 , bug 1103816 , and bug 1104651 to try the current port.
Comment on attachment 8539005 [details] [diff] [review]
bug-1107301.patch

It looks like already in hg central.
Attachment #8539005 - Flags: review?(jld)
Change this meta bug's summary to [meta]audio/video.

B2G lollipop release should support SW/HW decoding.
Summary: [meta] Audio Android L Porting → [meta] Audio/Video Android L Porting
QA Whiteboard: [2.2-feature-qa+] → [2.2-feature-qa+][COM=Gaia::Video]
Component: General → Gaia::Video
Status: NEW → ASSIGNED
(In reply to Michael Wu [:mwu] from comment #9)
> What are these patches for? Audio seems to work fine for me. We don't build
> libstagefright_http_support.
> 
> ./config.sh nexus-5-l and apply the patches from bug 1102266 , bug 1103816 ,
> and bug 1104651 to try the current port.

Hi Michael,

after apply 3 patches, still have error. Is there any patch I also need to apply? 

Thanks
I got the same compile error too and it is caused by bug 938034. Now I filed a bug 1113655 to fix this.
Comment on attachment 8538977 [details] [review]
remove dependency of libandroid_runtime

Clearing review. All the patches have landed on b2g-inbound and the build should work once b2g-inbound merged to m-c. Let me know if you still need additional patches.
Attachment #8538977 - Flags: review?(mwu)
 Michael has done those related jobs for audio porting, set duplicate.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112312
Target Milestone: --- → 2.2 S3 (9jan)
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.