Closed Bug 1107349 Opened 5 years ago Closed 5 years ago

Always build GGC features into SpiderMonkey

Categories

(Core :: JavaScript: GC, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: terrence, Assigned: terrence)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

85 files changed, 26 insertions(+), 486 deletions(-)

Embedders that don't yet support generational can disable it at runtime with DisableGenerationalGC, at a small runtime cost.
Attachment #8531796 - Flags: review?(jcoppeard)
Comment on attachment 8531796 [details] [diff] [review]
always_build_in_generational-v0.diff

Review of attachment 8531796 [details] [diff] [review]:
-----------------------------------------------------------------

Great.
Attachment #8531796 - Flags: review?(jcoppeard) → review+
Duplicate of this bug: 1022574
https://hg.mozilla.org/mozilla-central/rev/3d0a1db612fa
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.