[Status Bar][Bluetooth] Status bar turns black when the device is connected with another device via Bluetooth.

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: gmarty)

Tracking

({regression})

unspecified
2.2 S2 (19dec)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-flame-reduced-run][systemsfe], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8531800 [details]
logcat_20141203_StatusbarTurningBlack.txt

Description:
After the device is paired with another device via Bluetooth, the staus bar turns black. 
   
Repro Steps:
1) Update a Flame device to BuildID: 20141203040207.
2) Go to Settings > Bluetooth > Enable Bluetooth.
3) Pair with another device.
  
Actual:
The status bar turns black.

Expected: 
The status bar displays minimized rocket bar, icons, and the time.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb, KK, Full Flash)
BuildID: 20141203040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2129/
See attached: video clip, logcat
http://youtu.be/4TJAA7LGgKw
(Reporter)

Comment 1

4 years ago
This issue does NOT reproduce on Flame 2.1.

Result: The status bar does not turn black and is displayed properly after pairing up with another device via Bluetooth.

Device: Flame 2.1 (319mb, KK, Full Flash)
Build ID: 20141203001205
Gaia: dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko: ebce587d2194
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
This is a bad regression from 2.1 so nominating 2.2? The user should always be able to see their status bar.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
QA Contact: jmercado
Flags: needinfo?(dharris) → needinfo?
Bug 1095142 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141121050316
Gaia: 05d80f0af85c690e098828ed3e548b144afd904b
Gecko: 7e086b657030
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141121060312
Gaia: 012a9d7a77942f3cf267b60c6a2c756c2b8bfea0
Gecko: e8ed47c494f5
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 05d80f0af85c690e098828ed3e548b144afd904b
Gecko: e8ed47c494f5

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 012a9d7a77942f3cf267b60c6a2c756c2b8bfea0
Gecko: 7e086b657030

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/05d80f0af85c690e098828ed3e548b144afd904b...012a9d7a77942f3cf267b60c6a2c756c2b8bfea0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo? → needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Broken by patch for Bug 1095142  - can you take a look Guillaume?
Blocks: 1095142
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gmarty)
QA Contact: jmercado
Assignee: nobody → b.mcb
Created attachment 8532483 [details] [review]
Proposed patch

The attention window is not removed from the current instances, so what  we need to check if there is another instance opened to decide if remove or not the |attention| class

Thanks
Attachment #8532483 - Flags: review?(alive)
Attachment #8532483 - Flags: feedback?(gmarty)
After further testing, I found that this issue also happens on the 'Clock' app.

Summary:
Set an alarm. Once the alarm goes off and you close the alarm page, the status bar, when on the clock app, will be gone. Closing and reopening the app does not fix the problem. Only restarting the device will bring the bar back.

Repro:
1. Flash to version 20141205040202
2. Open Clock app
3. Set an alarm and let it go off
4. Close the alarm page

Expected:
User is brought back to clock page and status bar is visible

Actual:
Status bar is black

Environmental Variables:
Device: Flame 2.2(319mb)(KitKat)(Full Flash)
Build ID: 20141205040202
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: e7f3e6fee15e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2
Build ID: 20141205040202
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: e7f3e6fee15e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 100%
(Assignee)

Comment 7

4 years ago
Comment on attachment 8532483 [details] [review]
Proposed patch

I had a similar patch that I wanted to write tests for. So looks good to me.
Flags: needinfo?(gmarty)
Attachment #8532483 - Flags: feedback?(gmarty) → feedback+
Comment on attachment 8532483 [details] [review]
Proposed patch

I didn't reviewed that part.
IMO, what we should do is not pollute #screen, but let software home button to listen to hierarchychanged event to show/hide itself.
Attachment #8532483 - Flags: review?(alive) → review?(etienne)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1108152
Comment on attachment 8532483 [details] [review]
Proposed patch

(In reply to Alive Kuo [:alive][NEEDINFO!][PDXww until 12/5] from comment #8)
> Comment on attachment 8532483 [details] [review]
> Proposed patch
> 
> I didn't reviewed that part.
> IMO, what we should do is not pollute #screen, but let software home button
> to listen to hierarchychanged event to show/hide itself.

Well we still need a test for this to be r+'ed :)

BTW, talked with Alive about the #screen pollution (not related to the fix here) and we're going to remove the screen.locked and screen.attention altogether.
Attachment #8532483 - Flags: review?(etienne)
(Assignee)

Comment 11

4 years ago
[Blocking Requested - why for this release]:
This is a dupe of Bug 1107355.
We need to carry over the 2.1+ flag from Bug 1107355 so that we can close it?
blocking-b2g: 2.2? → 2.1?
(Assignee)

Comment 12

4 years ago
Obviously, I meant Bug 1106908. Damn jetlag.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1106908
Depends on: 1109091
Since 1106908 is 2.1+
blocking-b2g: 2.1? → 2.1+
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1109091
Whiteboard: [2.2-flame-reduced-run] → [2.2-flame-reduced-run][systemsfe]
(Assignee)

Comment 16

4 years ago
Hey Manuel. Are you working on tests or do you want me to take over from you? This issue is annoying for people dogfooding on master... like me :-)
Flags: needinfo?(b.mcb)
(Assignee)

Comment 17

4 years ago
Created attachment 8535596 [details] [review]
Github PR

I'm stealing this bug from Manuel.
Etienne, I wrote a minimal test to make sure we don't regress here, because we're going to get rid of this global class thing anyway. Can you have a look?
Attachment #8532483 - Attachment is obsolete: true
Flags: needinfo?(b.mcb)
Attachment #8535596 - Flags: review?(etienne)
(Assignee)

Updated

4 years ago
Assignee: b.mcb → gmarty
Comment on attachment 8535596 [details] [review]
Github PR

A bit internal but we know this will eventually go away :)
Thanks, lets land this! (without forgetting the one important comment on github)
Attachment #8535596 - Flags: review?(etienne) → review+
(Assignee)

Comment 19

4 years ago
Landed in master in https://github.com/mozilla-b2g/gaia/commit/184fd03aa986dd422275ca34af58f571426ae96a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

4 years ago
Comment on attachment 8535596 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Attention window and software home button
[User impact] if declined: Whenever an attention window is opened, the status bar turns black and even disappears under some circumstances.
[Testing completed]: This patch is unit tested. Manual testing is also required though.
[Risk to taking this patch] (and alternatives if risky): Very low impact as the change itself is a one-liner.
[String changes made]: None.
Attachment #8535596 - Flags: approval-gaia-v2.1?(bbajaj)

Updated

4 years ago
Keywords: verifyme
Comment on attachment 8535596 [details] [review]
Github PR

QA, please help verifye once this lands.
Attachment #8535596 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+

Comment 22

4 years ago
Verified the issue is fixed on 2.2 Flame

No black status bar appears when the bluetooth is connected

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141215040201
Gaia: e2a3e606675c346b6e6f35351a458040be599b09
Gecko: f14dcd1c8c0b
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: affected → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Sorry, this approval got missed earlier due to the status flag being set to unaffected. Please ensure that the flags are properly set when requesting/granting approval.

v2.1: https://github.com/mozilla-b2g/gaia/commit/af0131a6ba7bf12ac3dc4d94225a7f4e62589ecb
status-b2g-v2.1: unaffected → fixed
Target Milestone: --- → 2.2 S2 (19dec)

Updated

4 years ago
status-b2g-v2.1S: --- → fixed
You need to log in before you can comment on or make changes to this bug.