Password manager guesses username field incorrectly

VERIFIED DUPLICATE of bug 153986

Status

--
minor
VERIFIED DUPLICATE of bug 153986
17 years ago
14 years ago

People

(Reporter: greenrd, Assigned: morse)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011115
BuildID:    2001111512

On the above URL Password Manager thinks that the search field is the "username"
field, rather than the library number field. It should be possible to guess
correctly, given that the username fields won't tend to be described as "search"
fields, and the library number field is right next to the password field.

Reproducible: Always
Steps to Reproduce:
1. Go to URL above
2. Enter random library card number and password
3. Return to URL
4. Enter another random library card number and password
5. Return to URL


Actual Results:  Password manager asks you to choose between <> and <> for the
username

Expected Results:  Should ask you to choose between the actual library card
numbers you entered.
(Assignee)

Comment 1

17 years ago
Password manager doesn't do any screen scraping or use any other 
sophisticated algorithm for determining user names.  Rather it heuristically 
takes the first textfield to be the "username" by definition.  The "username" is 
just a handle that password manager uses for identifying the form.

This heuristic works for the vast majority of login forms.  But being a 
heuristic, it will not work in 100% of the cases.  The particular form sited in 
this bug report is one of the rare cases in which it will not work.

My recommendation is simply not to use password manager on this form.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 2

16 years ago
Dup of 153986.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 153986 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.