[Midori 2.0][HOMO][OS2.0 62162]Some popular audio formates cannot be downloaded via OMA-DD

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Browser
P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
FFOS2.0 baseline BuildID: 20140916000205
 
 Description: 
 Some popular audio formates are not supported for OMA-DD download though the device supports these file types for playback in general:
 
 The device does not support:
 Audio/amr
 Audio/aac
 Video/3gpp
 Video/mp4
 
 Error message shown:
 "This type of purchased media is not supported on your phone"
 [err_unsupported_type: <MIME-Type>]
 
 Customer Impact Statement: 
 Customers will not be able to download and play many music/video files via OMA-DD.
 
 Expected Behaviour:
 Popular audio/vide media formats shall be supported.
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

3 years ago
blocking-b2g: --- → 2.2?

Comment 1

3 years ago
Is there a plan to implement the feature?
Aus, any idea if this is a feature request or a bug?
Flags: needinfo?(aus)
Whiteboard: [systemsfe]

Comment 3

3 years ago
I believe this is a feature request. We do not support using OMA Download Descriptor files at this time as far as I know.

Flagging :dkuo for confirmation.
Flags: needinfo?(aus) → needinfo?(dkuo)

Comment 4

3 years ago
Hmmm... actually it looks like we should support downloading via OMA DD files as per bug 971618.
This is filed as a 2.0 bug. Can QA verify that this works on master?
Keywords: qawanted

Comment 6

3 years ago
The build use to test this is too old. It would appear that the feature is available in 2.0 builds 20141126000203 and *later*. The tests executed to file this bug were done on build 20140916000205 which is not recent enough.

ChengLin.Wu, please retest with a more recent 2.0 build. As noted above, it must be build id 20141126000203 or *later*.

If this works as expected, please close as INVALID.

Thanks!
Flags: needinfo?(dkuo) → needinfo?(wuchlin)

Comment 7

3 years ago
(In reply to Ghislain Aus Lacroix [:aus] from comment #6)
> The build use to test this is too old. It would appear that the feature is
> available in 2.0 builds 20141126000203 and *later*. The tests executed to
> file this bug were done on build 20140916000205 which is not recent enough.
> 
> ChengLin.Wu, please retest with a more recent 2.0 build. As noted above, it
> must be build id 20141126000203 or *later*.
> 
> If this works as expected, please close as INVALID.
> 
> Thanks!

The oma does not update from 20140916000205. These format is not support:
Audio/amr
Audio/aac
Video/3gpp
Video/mp4

We should support more drm files.
Flags: needinfo?(wuchlin)
This issue does not seem to reproduce on the latest builds for 2.2 Flame, 2.1 Flame, or 2.0 Flame.  I was able to download all of the listed file types without issue.

Environmental Variables:
Device: Flame 2.2
BuildID: 20141215105338
Gaia: c5b01c018e79a36d7ca1e466c143c76fac7da705
Gecko: 5d6e0d038f95
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20141215103237
Gaia: 97873dca486abf4162a3345e71b375806937bdec
Gecko: 69d8f4b359cc
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0
BuildID: 20141212170645
Gaia: f3b9806f687fbbd7eba6b0e1f6ebb8bde09840ea
Gecko: 28bacbc71efb
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawanted

Comment 9

3 years ago
I'm going to go ahead and mark this WFM. The OEM will need to update their 2.0 build to include the bits necessary for OMA-DD support.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 10

3 years ago
!blocking
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.