Closed Bug 1107399 Opened 10 years ago Closed 9 years ago

[e10s] Adblock Edge's first-run page and about:addons page's "Filter Preferences" button do not load correctly with e10s enabled

Categories

(Firefox :: Extension Compatibility, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
e10s - ---

People

(Reporter: cpeterson, Unassigned)

References

Details

(Keywords: addon-compat)

Adblock Edge seems to block ads correctly, but I have to use the "Tools > Adblock Edge > Filter Preferences" menu item instead of about:addons' "Filter Preferences" button.
I can confirm what you are seeing with the "first run" `Filter Preferences` link (in chrome://adblockedge/content/ui/firstRun.xhtml ) not working (only with e10s enabled).  Looks like it's something in /chrome/content/ui/FirstRun.js in function openFilters() .

However, I am not able to reproduce the second part; when I go to about:addons -> Extensions -> Adblock Edge Options -> "Filter Preferences" - the button works for me, albeit it takes longer to load than with e10s disabled.

Another issue that arises with e10s enabled is that where firstRun.xhtml reads: "The following filter list has been configured to block advertising: 'No filter list' " should read 'Easylist'(works properly with e10s disabled) and have a link to the filter homepage.

I'll keep digging.
Telemetry is reporting that ABE is regularly throwing exceptions at contentPolicy.js ln 390
This addon has been discontinued.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Adblock Edge? It appears to still be active.
Flags: needinfo?(arenlor)
(In reply to Jorge Villalobos [:jorgev] from comment #4)
> Adblock Edge? It appears to still be active.

Right from the add-on's page: **This addon has been discontinued**
https://addons.mozilla.org/en-US/firefox/addon/adblock-edge/
Flags: needinfo?(arenlor)
You need to log in before you can comment on or make changes to this bug.