[Flame][First Time Experience]There is no alert after inputting email in firefox accounts view without network.

RESOLVED INVALID

Status

Firefox OS
Gaia::First Time Experience
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8531971 [details]
logcat.txt

[1.Description]:
[Flame][v2.1][First Time Experience]While we not connecting to network, a  "About firefox OS" view  appeared,input any email and tap done,we don't known whether the email was saved,there is no information in settings.
Occurence time:10:08
see attachments:logcat.txt,1.3gp.
[2.Testing Steps]: 
1.Launch first time use in develop.
2.Tap next to the second "About firefox OS" view.
3.Input any email.
4.Tap Done.
5.Tap skip.
6.Launch settings and check the firefox accounts.

[3.Expected Result]: 
6.We don't know what the function of step3 is,whether the email was saved successfully, or it should be displayed in settings?

[4.Actual Result]: 
6."Create account or sign in" view displayed.

[5.Reproduction build]: 
Flame 2.1 new versions:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0


[6.Reproduction Frequency]: 
Always Recurrence,3/3
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8531972 [details]
1.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → affected

Comment 2

3 years ago
Created attachment 8570869 [details]
fail log: logcat_415.txt

Hi Mike,
This issue still exists on latest Flame 2.1

See log: logcat_415.txt
STR:
1.Launch first time use in develop.
2.Tap next to the second "About firefox OS" view.
3.Input any email.
4.Tap Done.
5.Tap skip.
6.Launch settings and check the firefox accounts.

Flame 2.1 build:
Build ID               20150227002636
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.035555
Firmware Date          Fri Feb 27 03:56:06 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(mlien)

Comment 3

3 years ago
ni NoJun since he created the Firefox Accounts test cases before.
Hi NoJun, do we have any alert if there has no network in this case?
Flags: needinfo?(mlien) → needinfo?(npark)
Usually what happens is that after the email address has been entered, if it doesn't find the matching account, the user will be taken to the "Create account or sign in" page.  If the network is still unavailable, then the error should be generated after providing information past the create account or sign in page.  So to me this is behaving as designed.
Flags: needinfo?(npark)

Comment 5

3 years ago
refer to comment 4, mark as INVALID
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.