Flash XBL bindings cause SWF files not to display

RESOLVED WORKSFORME

Status

()

Core
XBL
--
critical
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: ominds, Unassigned)

Tracking

34 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.85 KB, application/x-xpinstall
Details
(Reporter)

Description

3 years ago
Created attachment 8532004 [details]
XPI with very simple test case

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

Install the test XPI file attached. What it does is simply do XBL binding to flash tags, the XBL binding file itself is empty (doesn't do anything). Please note this is affected FlashFirebug users and all flash no longer shows. So it's very critical.

You can test with this SWF http://o-minds.com/products/flashfirebug/tutorial


Actual results:

All SWFs are not displayed


Expected results:

All SWFs should be displayed
(Reporter)

Updated

3 years ago
Severity: normal → critical
(Reporter)

Comment 1

3 years ago
I'll add this worked fine with version 33.1.1, nothing else changed except upgrading to firefox 34.0, I naively thought the problem was with nightly, I should have filed it much earlier.

Actual broken extension:

https://addons.mozilla.org/en-US/firefox/addon/flashfirebug/
(Reporter)

Updated

3 years ago
Component: Untriaged → XBL
Product: Firefox → Core
A regression range on nightlies would probably help a good bit in pinning down what changed here...
Keywords: qawanted, regressionwindow-wanted
(Reporter)

Comment 3

3 years ago
I can install all builds between 33.1.1 until 34.0 to find the problem, but can you point me to where I can find them? I believe this is what you mean, right?
Yes, that's what I mean.  If you're willing to do that, it would be very helpful!

You can find development trunk nightly builds at http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/ in directories by month and by date within the month.  33 was based on code that branched from the development trunk on 2014-06-09 and 34 is based on code that branched on 2014-07-21.

There's also a tool at http://mozilla.github.io/mozregression/ that can somewhat automate the process of downloading and running the right builds to do a binary search on the date range.  Worth verifying that a nightly from Jun 9 doesn't have the bug and a nightly from Jul 21 does before starting with the tool, of course.

Comment 5

3 years ago
It is necessary to add bindToUntrustedContent="true" property to <binding>.
See Bug 1050049.
(Reporter)

Comment 6

3 years ago
You're totally right. After adding that property, all's working fine.

I've submitted a new version with only these additional properties and a version bump.

I wonder if someone can expedite it since I'm getting many support mails.

https://addons.mozilla.org/en-US/firefox/addon/flashfirebug/

Thanks again.
(Reporter)

Comment 7

3 years ago
By the way, test extension attached to this bug seems to be broken. Just in case someone sees this bug report in the future. Don't rely on it.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME

Updated

3 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.