If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Press N to see next unread message immediately without confirmation dialog

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
--
enhancement
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Steven Huang, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

1) Mailbox A has 0 unread messages. We are currently in mailbox A.
2) Mailbox B has 1 unread message.
3) Press the shortcut key (N) to go to the next unread message.


Actual results:

Confirmation dialog pops up to notify the user that the next unread message is not in the current mailbox.


Expected results:

While this behaviour seems to be intended, and rightfully so, for my usage I would like to have the choice to jump to the next unread message without having the confirmation dialog tell me the message I will jump to is in a different mailbox. 

Reasoning: 
1) personally, it is already very apparent which mailbox a message is under
2) can go through all my emails in all my accounts faster and with a less jarring experience

If there can even be a flag that can be set in the configs for advanced users, that would be awesome! Thanks.
(Reporter)

Updated

3 years ago
Severity: normal → enhancement

Comment 1

3 years ago
You're in luck, set the pref mailnews.nav_crosses_folders

     // 0: "next" goes to the next folder, without prompting
     // 1: "next" goes to the next folder, and prompts (the default)
     // 2: "next" does nothing when there are no unread messages
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

3 years ago
Hey that's great! Thanks for finding that for me.
You need to log in before you can comment on or make changes to this bug.