Titlebar elements aren't dark in Firefox devedition on Linux

RESOLVED FIXED in Firefox 37

Status

()

Firefox
Theme
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: vmoutoussamy, Assigned: bgrins)

Tracking

36 Branch
Firefox 37
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [devedition-polish])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8532032 [details]
top-right-firefox-white.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141128004001

Steps to reproduce:

Use the Firefox Developer Edition theme on Linux


Actual results:

The top right corner of Firefox is still white and doesn't have the black theme color


Expected results:

Have the black theme color
(Reporter)

Comment 1

3 years ago
It's the Firefox Developer Edition theme fault's, since any other theme does not have this white area. cf top-right-theme-firefox.png
(Reporter)

Comment 2

3 years ago
Created attachment 8532033 [details]
top-right-theme-firefox.png
(Reporter)

Comment 3

3 years ago
Created attachment 8532036 [details]
top-right-theme-firefox-without-Htile.png
(Reporter)

Updated

3 years ago
Summary: white area on top right corner with developer edition theme on linux → white area on top right corner with developer edition theme on Gnome
(Reporter)

Updated

3 years ago
Component: Untriaged → Theme
(Reporter)

Updated

3 years ago
Version: 35 Branch → 36 Branch

Comment 4

3 years ago
How come your tabs are in the titlebar in the first place? By default Firefox doesn't implement this on Linux.

Brian, I think we have a bug on the rest of the tabs toolbar not being dark on Linux, right?
Flags: needinfo?(vincent.moutoussamy)
Summary: white area on top right corner with developer edition theme on Gnome → Titlebar elements aren't dark in Firefox devedition on Linux
Whiteboard: [devedition-polish]
(Assignee)

Comment 5

3 years ago
(In reply to :Gijs Kruitbosch from comment #4)
> How come your tabs are in the titlebar in the first place? By default
> Firefox doesn't implement this on Linux.
> 
> Brian, I think we have a bug on the rest of the tabs toolbar not being dark
> on Linux, right?

Not exactly, we do have Bug 1096180 that is about a more specific problem (the default background showing up during tab closing and/or with tabs in titlebar).  I believe fixing this may resolve 1096180 as well.

As far as this goes, most likely we are missing a `-moz-appearance: none` in certain conditions, like with a customized button put in the tab strip
Blocks: 1096180
(Assignee)

Comment 6

3 years ago
Gijs, there is a CSS rule that sets the -moz-appearance for non-lw-theme #TabsToolbar here: http://dxr.mozilla.org/mozilla-central/source/browser/themes/linux/browser.css#1775.

Changing that to 'none' for the devedition theme seems to fix this problem, but I'm not sure if this would cause other problems.  If it's not setting -moz-appearance for lw themes, it can't be that bad, can it?
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

3 years ago
(In reply to Brian Grinstead [:bgrins] from comment #6)
> Gijs, there is a CSS rule that sets the -moz-appearance for non-lw-theme
> #TabsToolbar here:
> http://dxr.mozilla.org/mozilla-central/source/browser/themes/linux/browser.
> css#1775.
> 
> Changing that to 'none' for the devedition theme seems to fix this problem,
> but I'm not sure if this would cause other problems.  If it's not setting
> -moz-appearance for lw themes, it can't be that bad, can it?

Yeah, moz-appearance: none sounds like the right solution here. :-)
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Comment 8

3 years ago
Created attachment 8540416 [details] [diff] [review]
linux-tabbar.patch

This fixes the issue for me with a customized tab bar on Ubuntu.  I haven't figured out how to test that tabs in titlebar scenario, but it looks like the same problem.

Here is a try push just in case gamebouille is able to test it and let me know if it fixes it: https://tbpl.mozilla.org/?tree=Try&rev=25d470c1b0ab
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8540416 - Flags: review?(gijskruitbosch+bugs)

Updated

3 years ago
Attachment #8540416 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 9

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/e22433270ec3
Whiteboard: [devedition-polish] → [fixed-in-fx-team][devedition-polish]
https://hg.mozilla.org/mozilla-central/rev/e22433270ec3
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team][devedition-polish] → [devedition-polish]
Target Milestone: --- → Firefox 37
(Reporter)

Updated

2 years ago
Flags: needinfo?(vincent.moutoussamy)
You need to log in before you can comment on or make changes to this bug.