Changing request "Host" header using netmonitor's "Edit and Resend" does not work

RESOLVED DUPLICATE of bug 1270096

Status

()

Firefox
Developer Tools: Netmonitor
P2
normal
RESOLVED DUPLICATE of bug 1270096
4 years ago
2 years ago

People

(Reporter: Jon, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113113219

Steps to reproduce:

Similar to Bug 1009748, but a different header.

- Open https://bugzilla.mozilla.org/
- Open developer tools
- Click Network tab
- Select the main HTML request; hit Edit Resend
- Modify the "Host" to "foo.bugzilla.mozilla.org"
- Click "Send"

- Sent the request


Actual results:

Analyze the request and notice the Host header was reverted to "bugzilla.mozilla.org".


Expected results:

The request should have been sent with the Host header "foo.bugzilla.mozilla.org". This can be useful for testing web server configurations. I could then analyze the request/response.

If this request header is _never_ editable, it is ver misleading to allow it.
(Reporter)

Updated

4 years ago
Component: Untriaged → Developer Tools: Netmonitor

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 982603
I don't think this should be marked as a duplicate.  It's not clear to me that it's the same issue.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Depends on: 1270096
Priority: -- → P2
Fixed in bug 1270096.
Status: NEW → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1270096
You need to log in before you can comment on or make changes to this bug.