onresize is not fired when resizing devtools

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
3 months ago

People

(Reporter: blainekasten, Unassigned)

Tracking

37 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

1. Have a `window.onresize` event handler.
2. Reload with devtools open
3. Resize devtools


Actual results:

Nothing happened when resizing the devtools


Expected results:

I expected the onresize event handler to be fired when the devtools was resized as the window should be resized then also.
(Reporter)

Updated

4 years ago
Component: Untriaged → Webapp Runtime
Component: Webapp Runtime → Developer Tools

Comment 1

4 years ago
I can't reproduce this. STR:

1. open devtools' console
2. window.onresize = function() { console.log('resize'); }
3. drag top of devtools box up or down

When doing this, I see 'resize' being logged just fine.

Is this not what happens in your case? If this test scenario does work, what's different in yours? What version of Firefox are you testing on?
Flags: needinfo?(blainekasten)
(Reporter)

Comment 2

4 years ago
I am failing to reproduce this now also. This can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(blainekasten)
Resolution: --- → INVALID

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.