Closed Bug 1107581 Opened 8 years ago Closed 8 years ago

make NS_StackWalk less awful on Windows

Categories

(Core :: XPCOM, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1088343

People

(Reporter: froydnj, Unassigned)

Details

I couldn't find the other open bug that supposedly existed on this, so I filed a new one.  I know very little about things here, so feel free to fill in details, and/or duplicate this bug.

NS_StackWalk on Windows uses dbghelp.dll, which limits us in a number of ways.  We should stop doing that, particularly because there exists a significantly better way to do it on Win64.
I think it was bug 1088343.
I believe the suggestion was to use RtlVirtualUnwind (or another RtlSomething function) instead of StackWalk64?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.