[Lockscreen] After swiping to unlock (to reach passcode screen), your post-swipe touch-removal is interpreted as a number press

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR:
 1. In Settings | Screen Lock, enable both "Lock Screen" & "Passcode Lock", and set "Require Passcode" to "Immediately".

 2. Power your phone's display off and then on, so you see the lockscreen.


 3. Swipe the button on the lockscreen towards the "unlock" icon, **AND KEEP YOUR FINGER ON THE SCREEN**.

  --> Now you'll be prompted to enter a passcode. Your finger is probably currently on top of the "9" key. (if it's not, maybe slide it slightly to be clearly over a number key)

 4. Remove your finger from the phone, to start entering your passcode.

ACTUAL RESULTS:
When you remove your finger, it's interpreted as a keypress of whatever number-key you're currently on top of. (probably a "9")

EXPECTED RESULTS: Nothing should happen when you remove your finger.


I hit this bug by accident, at least once a day, just through normal use. (It's 100% reproducible, if I intentionally try to trigger it.) I'm using a Flame, on the 2.1 nightly channel.

Build Identifier: 20141204001201
Update channel: nightly-b2g34
Git commit info: 2014-12-03 14:30:59  56552690
(Reporter)

Updated

4 years ago
Summary: [Lockscreen] After swiping to unlock (& reach passcode screen), your touch-removal is interpreted as a number press → [Lockscreen] After swiping to unlock (to reach passcode screen), your post-swipe touch-removal is interpreted as a number press
(Reporter)

Comment 1

4 years ago
I think I first noticed this bug in the past few weeks. I'm not sure if it's because it regressed recently, or if I was just lucky enough / fast enough to never hit it before then.
(Reporter)

Comment 2

4 years ago
(In reply to Daniel Holbert [:dholbert] from comment #0)
>  3. Swipe the button on the lockscreen towards the "unlock" icon, **AND KEEP
> YOUR FINGER ON THE SCREEN**.

Note: In 2.2 (on mhenretty's phone), we stay at the lockscreen until you remove your finger from the screen. In 2.1 on my phone, we go to the passcode screen pretty much as soon as I swipe the icon all the way to the right, even if my finger is still on the screen. That might be the fundamental problem here.
Flags: needinfo?(mhenretty)
(Reporter)

Comment 3

4 years ago
mhenretty helpfully discovered that this is due to a dead touch-area at the
bottom-right of my Flame's screen!

So, INVALID as a software bug
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mhenretty)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.