Closed Bug 1107747 Opened 7 years ago Closed 7 years ago

Create build for device branch 2.1s

Categories

(Release Engineering :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:2.1S+, b2g-v2.1S fixed, b2g-v2.2 wontfix, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.1S+
Tracking Status
b2g-v2.1S --- fixed
b2g-v2.2 --- wontfix
b2g-master --- fixed

People

(Reporter: seinlin, Assigned: seinlin)

References

Details

Attachments

(8 files, 5 obsolete files)

14.54 KB, patch
hwine
: review+
rail
: review+
Details | Diff | Splinter Review
643 bytes, patch
hwine
: review+
Details | Diff | Splinter Review
874 bytes, patch
rail
: review+
Details | Diff | Splinter Review
4.60 KB, patch
nthomas
: review+
Details | Diff | Splinter Review
18.75 KB, patch
seinlin
: review+
Details | Diff | Splinter Review
18.24 KB, patch
Details | Diff | Splinter Review
808 bytes, patch
nthomas
: review+
Details | Diff | Splinter Review
503 bytes, patch
catlee
: review+
pmoore
: checked-in+
Details | Diff | Splinter Review
No description provided.
Attached patch bug-1107747-part-1.patch (obsolete) — Splinter Review
Hal, Could you review this patch? Thanks!
Attachment #8532286 - Flags: review?(hwine)
Attached patch bug-1107747-part-2.patch (obsolete) — Splinter Review
Hal, Could you review this patch? Thanks!
Attachment #8532288 - Flags: review?(hwine)
Blocks: 1107616
Comment on attachment 8532286 [details] [diff] [review]
bug-1107747-part-1.patch

Review of attachment 8532286 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8532286 - Flags: review?(hwine) → review+
Comment on attachment 8532288 [details] [diff] [review]
bug-1107747-part-2.patch

Review of attachment 8532288 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8532288 - Flags: review?(hwine) → review+
Running test-masters.sh is Passed.
Comment on attachment 8532288 [details] [diff] [review]
bug-1107747-part-2.patch

backed out due to bustage found by sheriffs. 's' missing on a number of device builds, disabling them on 2.1 instead

backout commit:
 http://hg.mozilla.org/build/buildbot-configs/rev/2cc554bc3a33
Attachment #8532288 - Flags: checked-in+ → checked-in-
Please fix the config, and re-attach for review. My apologies for missing this in PDX.
Flags: needinfo?(kli)
Hal, Thanks! We'll re-attach for review and land it after it is fixed.
Flags: needinfo?(kli)
Depends on: 1115297
blocking-b2g: --- → 2.1S+
Kai-Zhen, bug 1115297 is already fixed. Could you please help with this one?
Flags: needinfo?(kli)
Peipei, OK, I will do that. But the target device for v2.1s got some changes, so I need to finish bug 1120745. Keep NI for todo.
Depends on: 1120745
Hwine, Now branch 2.1s is ready. Could you review this patch? Thanks!
Assignee: nobody → kli
Attachment #8532288 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8548911 - Flags: review?
Flags: needinfo?(kli)
Attachment #8548911 - Flags: review? → review?(hwine)
Hwine, We need to add short name for dolphin, otherwise dolphin-512 will get error in test-masters.sh because of len > 30. Could you review this patch? Thanks!
Attachment #8548914 - Flags: review?(hwine)
Comment on attachment 8532286 [details] [diff] [review]
bug-1107747-part-1.patch

This is already landed.
Attachment #8532286 - Attachment is obsolete: true
Hwine, Could you review this patch? Thanks!
Attachment #8548917 - Flags: review?(hwine)
Nick, We need to add a new device config. Could you review this patch? Thanks!
Attachment #8548924 - Flags: review?(nthomas)
Attached patch bug-1107747-mozharness.patch (obsolete) — Splinter Review
Nick, Could you review this patch? Thanks!
Comment on attachment 8548911 [details] [diff] [review]
bug-1107747-buildbot-configs.patch

Driveby comment ....

>diff --git a/mozilla/b2g_config.py b/mozilla/b2g_config.py
>+# dolphin-512 is for selected branches only
>+for branch in BRANCHES:
>+    if branch not in ('mozilla-b2g34_v2_1s'):

This needs to have a trailing comma in the tuple, ie 
    if branch not in ('mozilla-b2g34_v2_1s',):
Comment on attachment 8548924 [details] [diff] [review]
Add in-tree files for dolphin-512 on master.

Seems fine. I see you've not copied b2g/config/dolphin/releng-dolphin.tt over, could you comment on why that is ? (for anyone who comes an looks at this bug later).
Attachment #8548924 - Flags: review?(nthomas) → review+
Comment on attachment 8548924 [details] [diff] [review]
Add in-tree files for dolphin-512 on master.

Actually, I don't think you need this patch, because the buildbot patch isn't adding dolphin-512 builders on master (aka mozilla-central), just 2.1s.
Comment on attachment 8548945 [details] [diff] [review]
bug-1107747-mozharness.patch

Review of attachment 8548945 [details] [diff] [review]:
-----------------------------------------------------------------

Could you clarify where dolphin-512 builds are going to run ? If it's only 2.1s then changes to master.py, v2.1.py and v2.2.py are unnecessary.

::: configs/b2g_bumper/v2.1s.py
@@ +7,5 @@
> +        "gittool.py": ["/usr/local/bin/gittool.py"],
> +    },
> +    'gecko_pull_url': 'https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/',
> +    'gecko_push_url': 'ssh://hg.mozilla.org/releases/mozilla-b2g34_v2_1/',
> +    'gecko_local_dir': 'mozilla-b2g34_v2_1',

Looks like you've done a copy of v2.1.py, and these three need updating.

@@ +11,5 @@
> +    'gecko_local_dir': 'mozilla-b2g34_v2_1',
> +    'git_ref_cache': '/builds/b2g_bumper/git_ref_cache.json',
> +
> +    'manifests_repo': 'https://git.mozilla.org/b2g/b2g-manifest.git',
> +    'manifests_revision': 'origin/v2.1',

And this.

@@ +19,5 @@
> +    "ssh_user": "ffxbld",
> +
> +    'hgtool_base_bundle_urls': ['https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/bundles'],
> +
> +    'gaia_repo_url': 'https://hg.mozilla.org/integration/gaia-2_1',

And this, and I'll stop looking now but please check for others.
Attachment #8548945 - Flags: review-
Hi Nick,

Yes, dolphin-512 will run on v2.1s only. I updated the patch, could you review it again when you have time? 

Thanks!
Attachment #8548945 - Attachment is obsolete: true
Attachment #8549303 - Flags: review?(nthomas)
(In reply to Nick Thomas [:nthomas] from comment #23)
> Comment on attachment 8548924 [details] [diff] [review]
> Add in-tree files for dolphin-512 on master.
> 
> Seems fine. I see you've not copied b2g/config/dolphin/releng-dolphin.tt
> over, could you comment on why that is ? (for anyone who comes an looks at
> this bug later).

To build dolphin and dolphin-512, we don't need the system backup tar file, because we can build all necessary binary from source.
Comment on attachment 8548914 [details] [diff] [review]
Add short name for dolphin.

Glad the tests caught this! :)
Attachment #8548914 - Flags: review?(hwine) → review+
Comment on attachment 8548917 [details] [diff] [review]
Add dolphin-512 for buildbot.

Review of attachment 8548917 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not familiar with the issues in adding a new device, :rail does.
Attachment #8548917 - Flags: review?(hwine) → review?(rail)
Comment on attachment 8548911 [details] [diff] [review]
bug-1107747-buildbot-configs.patch

new branch looks right, deferring to :rail for new device changes.
Attachment #8548911 - Flags: review?(rail)
Attachment #8548911 - Flags: review?(hwine)
Attachment #8548911 - Flags: review+
Attachment #8548917 - Flags: review?(rail) → review+
Comment on attachment 8548911 [details] [diff] [review]
bug-1107747-buildbot-configs.patch

Review of attachment 8548911 [details] [diff] [review]:
-----------------------------------------------------------------

In overall it looks good, but i requires another patch to make it work. I get the following errors trying to run the tests:

ValueError: Cannot shorten "b2g_mozilla-b2g34_v2_1_dolphin-512_eng_dep" to maximum length (30). Got to: b2g_m-b34_21_dolphin-512_eng_dep

You need to add a rule to shorten "dolphin" in http://hg.mozilla.org/build/buildbotcustom/file/2b02c9c12a9c/common.py#l48
(In reply to Rail Aliiev [:rail] from comment #31)
> Comment on attachment 8548911 [details] [diff] [review]
> bug-1107747-buildbot-configs.patch
> 
> Review of attachment 8548911 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> In overall it looks good, but i requires another patch to make it work. I
> get the following errors trying to run the tests:
> 
> ValueError: Cannot shorten "b2g_mozilla-b2g34_v2_1_dolphin-512_eng_dep" to
> maximum length (30). Got to: b2g_m-b34_21_dolphin-512_eng_dep
> 
> You need to add a rule to shorten "dolphin" in
> http://hg.mozilla.org/build/buildbotcustom/file/2b02c9c12a9c/common.py#l48

Rail, Thanks! I added a patch in comment 16 to fix it error. I think it should work.
Flags: needinfo?(rail)
Comment on attachment 8548911 [details] [diff] [review]
bug-1107747-buildbot-configs.patch

Oh, I missed that patch. With both applied it worked fine.

Thanks for your contribution and making our lives easier. :)
Flags: needinfo?(rail)
Attachment #8548911 - Flags: review?(rail) → review+
(In reply to Kai-Zhen Li [:seinlin] from comment #27)
> To build dolphin and dolphin-512, we don't need the system backup tar file,
> because we can build all necessary binary from source.

OK. I was confused by http://hg.mozilla.org/mozilla-central/file/default/b2g/config/dolphin/releng-dolphin.tt but that was only recently added.
Comment on attachment 8549303 [details] [diff] [review]
bug-1107747-mozharness.patch

>diff --git a/configs/b2g_bumper/v2.1s.py b/configs/b2g_bumper/v2.1s.py
>+    'gaia_repo_url': 'https://hg.mozilla.org/integration/gaia-2_1s',

This doesn't exist yet, please ask hwine/pmoore to set it up (if you haven't already). Otherwise looks fine.
Attachment #8549303 - Flags: review?(nthomas) → review+
Depends on: 1123159
Correct DEVICE name for dolphin-512, carry r+.
Attachment #8548924 - Attachment is obsolete: true
Attachment #8552202 - Flags: review+
Attachment #8548925 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/bf0e7704b8a4
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
buildbotcustom patch is in production
buildbot-config patch(es) are live in production
a mozharness patch has from this bug is in production
Nick, Could you review this patch for me? Thanks!
Attachment #8555000 - Flags: review?(nthomas)
Comment on attachment 8555000 [details] [diff] [review]
bug-1107747-quick-fix.patch

Confirmed this drops these two builders:
< b2g_mozilla-b2g34_v2_1_dolphin-512_periodic ScriptFactory
< b2g_mozilla-b2g34_v2_1_dolphin-512_eng_periodic ScriptFactory

leaving 4 on 2.1 (opt+eng, periodic+nightly).
Attachment #8555000 - Flags: review?(nthomas) → review+
Depends on: 1126137
Depends on: 1120950
Depends on: 1135202
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This v2.1s config was invalid, and causing mozharness to fail.

We were also not alerted (see bug 1135030) - note this has not been working since it landed several days ago.

This error was only discovered as a side effect of investigating bug 1136148, which was unrelated (an hg process hanging).
Attachment #8568562 - Flags: review?(catlee)
Attachment #8568562 - Flags: review?(catlee) → review+
Comment on attachment 8568562 [details] [diff] [review]
bug1107747_mozharness_fix-b2g-bumper-config_v1.patch

Landed on default, jlund will merge later today during a reconfig.

https://hg.mozilla.org/build/mozharness/rev/21f00dd7bda6
Attachment #8568562 - Flags: checked-in+
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.