Closed Bug 1107809 Opened 8 years ago Closed 8 years ago

language guesser is erroring out

Categories

(Input Graveyard :: Backend, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: willkg, Assigned: willkg)

Details

(Whiteboard: u=user c=feedback p=2 s=input.2014q4)

Starting 3:00am this morning, we started getting a bunch of these:

Task fjord.translations.tasks.translate_task with id 2b42336e-0459-416e-96c3-67f429f66a9b raised exception:
"ConnectionError(MaxRetryError('None: Max retries exceeded with url: /api/service/detect/language (Caused by redirect)',),)"

...

ConnectionError: HTTPConnectionPool(host='api2.gengo.com', port=80): Max retries exceeded with url: /api/service/detect/language (Caused by <class 'socket.gaierror'>: [Errno -2] Name or service not known)


That suggests a DNS resolution error.

That code is using an "unofficial" api endpoint for language detection. It looks like the domain name is no longer around.

This bug covers pinging the Gengo folks to find out if the api has moved or been removed. If it's been moved, we need to update the code. If it's been removed, we need to implement our own language guesser.
I traded emails with Spencer and Adam from Gengo and got the new API endpoint. They had done a massive API update on Thursday and since we're using an unofficial API endpoint, we have that endpoint hard-coded in our code.

New API endpoint fix in a PR: https://github.com/mozilla/fjord/pull/402
Assignee: nobody → willkg
Status: NEW → ASSIGNED
Whiteboard: u=user c=feedback p= s=input.2014q4 → u=user c=feedback p=1 s=input.2014q4
Landed in https://github.com/mozilla/fjord/commit/a0247582dda0eb92b39aca34f03efc67ffe67f37

Pushed this to prod just now.

Verified the language guesser is working correctly again.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: u=user c=feedback p=1 s=input.2014q4 → u=user c=feedback p=2 s=input.2014q4
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.