already running prompt is giving option to close the browser, why? when its open? it should offer a switch to option at the least, better yet switch it foreground

RESOLVED DUPLICATE of bug 985921

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 985921
4 years ago
4 years ago

People

(Reporter: noitidart, Unassigned)

Tracking

34 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8532434 [details]
why-close-they-should-show-a-switch-to-window.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

i run multi profiles.

you can see i have three profiles running. one has MDN icon badge. another Youtube icon bage, and a third unbadged.


i launched the youtube badged profile, not knowing i had it running. i got a prompt saying "its running" and a button to close or cancel. i dont want to close it, i want to switch to it. an option for this would be nice, better yet auto focus it.


Actual results:

see attached image: why-close-they-should-show-a-switch-to-window.png


Expected results:

swithced to the profile as its running and responsive.

also this close thing is misleading, as firefox may be responsive, it likely is, the user probably just closed it and is trying to start it back again. firefox shutdown process takes like up to 20 seconds, more then enough for user to decide he wants to open the browser again. instead they'll see the close button, and they'll force close firefox's shutdown processes

Comment 1

4 years ago
"Option to switch to another profile" is a request for a new feature, hence setting severity to enhancement.
Severity: normal → enhancement

Comment 2

4 years ago
Please see bug 985921 comment #2 - figuring out that the running instance it's trying to communicate with is shutting down is hard.

If the process is unresponsive while it's running, that's a separate issue, but the solution is not "just add a switch to" option. If you ran with --no-remote, you explicitly asked not to switch to a running instance, so adding such a button doesn't make sense. If you ran without it, switching to it is what it should have done, and you should file a bug explaining how to reproduce the state where the profile is running, but the new instance can't communicate with it and therefore can't open a new window and gives you this prompt.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 985921
You need to log in before you can comment on or make changes to this bug.