Closed Bug 1107836 Opened 5 years ago Closed 5 years ago

Possibility to disable video / mute when being first in the room

Categories

(Hello (Loop) :: Client, defect, P1, critical)

defect
Points:
1

Tracking

(firefox35+ fixed, firefox36+ fixed, firefox37 fixed)

VERIFIED FIXED
mozilla37
Iteration:
37.2
Tracking Status
firefox35 + fixed
firefox36 + fixed
firefox37 --- fixed
Blocking Flags:
backlog Fx35+

People

(Reporter: burnus, Assigned: standard8)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141201162954

Steps to reproduce:

If one creates a conversation and opens the chat window, one automatically shares audio and video - and one can also not turn off the video until the other person joins. 

One cannot click to disable audio/video.

WORSE: Even if one clicks on the camera symbol and chooses: "stop sharing", once the other person has joined, the camera is turned on again.
Forgot to mention that this is with Firefox 35beta.
Hey Mark -- This bug is very important to fix and get into Fx35.  Any chance you could look at this one today?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(standard8)
[Tracking Requested - why for this release]:
This impacts user privacy (sharing camera/mic). This bug means the user's camera data may be shared when the user doesn't want it to be.
Severity: normal → critical
backlog: --- → Fx35+
Priority: -- → P1
We should check with Sevaan what the expected UX is here. Although we could enable the buttons, what about when someone else is already in the room first?
Flags: needinfo?(standard8) → needinfo?(sfranks)
The pieces I'm most concerned about fixing ASAP:
1) Even if one clicks on the camera symbol and chooses: "stop sharing", once the other person has joined, the camera is turned on again.

2) User can't turn off the video until the other person joins.
First, let's make these buttons available, so the user can control whether they want to turn on/off their camera or audio from the conversation window: http://cl.ly/image/1d2C2f2a1C2i The user's actions here should remain when someone joins the conversation.

Link clickers should be given the ability to choose what they want to share when they join a conversation as well. We can edit the "Join the conversation" button to indicate what joining does (by including a camera icon http://cl.ly/image/12153j063K2t) and have a dropdown so they can join with Audio only: http://cl.ly/image/050s1G1T0T3I
Flags: needinfo?(sfranks)
(In reply to Tobias Burnus from comment #0)
> WORSE: Even if one clicks on the camera symbol and chooses: "stop sharing",
> once the other person has joined, the camera is turned on again.

This part is bug 1098437.
Just talked with Mark and he's planning to fix this part:

>If one creates a conversation and opens the chat window, one automatically shares audio and video - and one can also not turn off the video until the other person joins. 
>
>One cannot click to disable audio/video.
Assignee: nobody → standard8
Ok, this works for the buttons. When the remote party join the room, the state of mute is also maintained.

I'll file a follow-up for not showing the feedback view if no-one has joined the room.
Attachment #8534518 - Flags: review?(nperriault)
https://hg.mozilla.org/integration/fx-team/rev/4ca24827c506
Iteration: --- → 37.2
Points: --- → 1
Target Milestone: --- → mozilla37
https://hg.mozilla.org/mozilla-central/rev/4ca24827c506
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8534518 [details] [diff] [review]
Allow the local video and audio to be muted whilst in the invitiation view for Loop's rooms.

Approval Request Comment
[Feature/regressing bug #]: Rooms

[User impact if declined]: Privacy issue - you can't wait in a muted state, and someone may join at any point.

[Describe test coverage new/current, TBPL]: on m-c, manual test

[Risks and why]: Very low - only a tiny CSS change to expose the existing buttons.

[String/UUID change made/needed]: none
Attachment #8534518 - Flags: approval-mozilla-beta?
Attachment #8534518 - Flags: approval-mozilla-aurora?
Attachment #8534518 - Flags: approval-mozilla-beta?
Attachment #8534518 - Flags: approval-mozilla-beta+
Attachment #8534518 - Flags: approval-mozilla-aurora?
Attachment #8534518 - Flags: approval-mozilla-aurora+
Tobias, this should be fixed in the latest Nightly and Aurora builds. It should also be fixed in the next Beta we release. Can you please confirm?
Flags: qe-verify-
Flags: needinfo?(burnus)
Yes, the issue is fixed in the last beta.

(Still, it would be nice to be able to open the conversation window with only audio enabled; currently, it turns on both and one can then only turn audio/video off.)
Flags: needinfo?(burnus)
(In reply to Tobias Burnus from comment #16)
> Yes, the issue is fixed in the last beta.

Thanks

> (Still, it would be nice to be able to open the conversation window with
> only audio enabled; currently, it turns on both and one can then only turn
> audio/video off.)

Please file a new bug report describing your idea.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.