Closed Bug 1107849 Opened 5 years ago Closed 5 years ago

There's no min or max sidebar width set

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P3)

37 Branch
defect

Tracking

(firefox37 affected, firefox40 verified)

VERIFIED FIXED
Firefox 40
Tracking Status
firefox37 --- affected
firefox40 --- verified

People

(Reporter: avaida, Assigned: pbro)

References

Details

Attachments

(1 file, 1 obsolete file)

Reproducible on: Nightly 37.0a1 (2014-12-04).
Affected platform(s): Windows 7 64-bit, Ubuntu 12.04 LTS 32-bit, Mac OS X 10.9.5.

STR:
1. Launch Firefox.
2. Enable Timeline from: click menu button → Developert → Toggle tools → Toolbox options → click the checkbox next to 'Timeline'.
3. Access Timeline and record operations for a few seconds on a random website.
4. Select a marker.
5. Pull the left border of the sidebar to the right, until it reaches the browser window's margin.
6. Pull the left border of the sidebar to the left, until it reaches the browser window's margin.

ER:
* The sidebar has a minimum and a maximum width, so that it cannot be completely hidden.
* Once resized, the sidebar's width can be changed again.

AR:
The user is unable to change the width of the sidebar once it has been pulled completely to the left margin of the browser window.
Flags: qe-verify+
Moving into the Profiler component. Filter on GUTHRIE'S WAVY CAKES.
Component: Developer Tools: Timeline → Developer Tools: Profiler
Summary: [timeline] There's no min or max sidebar width set → There's no min or max sidebar width set
Priority: -- → P3
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
I've checked both the inspector and the netmonitor and here's how they do it:
- there's a class (devtools-main-content) on the main center panel, this class is meant exactly for this type of things and has a min-width defined,
- there's a min-width defined on the sidebar (250px).
/r/8083 - Bug 1107849 - Define a min/max width for the performance panel sidebar

Pull down this commit:

hg pull -r a58e7a230d1806f89b67d9be86d8b417d10ca6a6 https://reviewboard-hg.mozilla.org/gecko/
Attachment #8600884 - Flags: review?(vporof)
Something like this works. Is this what you had in mind?
I set the sidebar min-width to 50px, for symmetry with the min-width of the main waterfall panel, and also because there isn't a whole lot of information in the sidebar right now that would require a bigger min-width (also I think I may file a general bug for devtools to make sidebars min-widths globally a lot smaller, it's frustrating as a user when you can't get them out of the way sometimes).
(In reply to Patrick Brosset [:pbrosset] [:patrick] from comment #4)
> Something like this works. Is this what you had in mind?
> I set the sidebar min-width to 50px, for symmetry with the min-width of the
> main waterfall panel, and also because there isn't a whole lot of
> information in the sidebar right now that would require a bigger min-width
> (also I think I may file a general bug for devtools to make sidebars
> min-widths globally a lot smaller, it's frustrating as a user when you can't
> get them out of the way sometimes).

There's stackframes that require a longer with possibly, but we need to fix other bugs before even caring about this. Sidebar content is a bit ugly now.
Attachment #8600884 - Flags: review?(vporof) → review+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/55d489bb8ad5
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
Attachment #8600884 - Attachment is obsolete: true
Attachment #8618812 - Flags: review+
Verified as fixed using Firefox 40 beta 4 under Win 7 x64, Ubuntu 14.04 x86 and Mac OS X 10.9.5.

I noticed that the RECORDS area cannot be horizontally scrolled. Is this expected or has a bug already on file?
Thanks
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.