Mailing List double entry

RESOLVED DUPLICATE of bug 628035

Status

RESOLVED DUPLICATE of bug 628035
4 years ago
4 years ago

People

(Reporter: anjeyelf, Unassigned)

Tracking

31 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

Using Windows Vista and TB version 31.3.0
This is a new bug which occurred after this recent update.
Tested in TB Safe Mode to check it was not any addon conflict - Safe mode had no effect, so posting as new bug.

This is what I did:
Contact is not in any address book.
Personal Address Book has a Mailing List.
Double click on Mailing List to open 'Mailing List' manual entry window.
Type new contact email address eg: Joe Bloggs <jb@domain.co.uk>
click on OK to close entry window.



Actual results:

Select the Mailing list from the Directory Pane to view new entry.
Select the Mailing list from the directory Pane.
Joe Bloggs <jb@domain.co.uk> was entered twice in the Mailing List.
Select 'Personal Address Book' to check for entry; it was only entered once, so the record in the PAB was OK.

Selected the Mailing List and Deleted the duplicate.
Both PAB and Mailing List now correct - one entry in each.


Expected results:

Contact is not in any address book.
Personal Address Book has a Mailing List.
Double click on Mailing List to open 'Mailing List' manual entry.
Type new contact email address eg: Joe Bloggs <jb@domain.co.uk>
click on OK

Joe Bloggs <jb@domain.co.uk> should only be listed once in the Mailing List and once in the PAB.
Hi Anje, thanks for your continued contributions to track and document bugs, which is highly appreciated.

Above problem is known (bug 628035) and is currently fixed on Trunk (aka Daily) by bug 1061648. However, the fix perhaps doesn't do the right thing and seems to have introduced other regressions which we are currently looking at (bug 1106783).

The UX of this is ultimately confusing and I have been at the forefront of campaigning to get this fixed asap. U r right there should not be any duplicate entries at any time.

Fwiw, with Mailing list selected in folder list during editing/adding of mailing list properties, deleting the duplicates immediately after closing editing dialog, will usually delete the contact.
Selecting another item in folder list, then re-selecting the Mailing list will always show the true status, with duplicates removed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628035
You need to log in before you can comment on or make changes to this bug.