Is packed.js needed in Mochitests?

RESOLVED FIXED in Firefox 55

Status

defect
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: bc, Assigned: dbugs, Mentored)

Tracking

({good-first-bug})

Trunk
mozilla55
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

(Whiteboard: [lang=xul])

Attachments

(1 attachment)

packed.js is used in a number of tests:

http://dxr.mozilla.org/mozilla-central/search?q=packed.js

However, it is not packaged in the tests zip nor I think in the Mochitest extension.

http://dxr.mozilla.org/mozilla-central/source/testing/mochitest/MochiKit/mochitest.ini

http://dxr.mozilla.org/mozilla-central/source/testing/mochitest/jar.mn

Running the Mochitests does result in 404 errors due to the missing file, but I don't see that it makes a difference in the test results.

If packed.js is needed, we should make sure it is packaged in the tests zip and the extension.

If packed.js is not needed, we should remove references to it from our tests and perhaps remove it from the tree altogether.
two thoughts here:
1) our tests really suck if this is not available - maybe this is a cause of intermittents?
2) we probably don't need this at all

I guess the test here is to look at the 20 or so test files that load packed.js and run them locally to determine if they reference it or not.  The fun part here is that running it locally (via mach) will probably find packed.js.

BC: the tests we run on Android do no print out an error in the logs, are we running different tests via autophone mochitest, or is something else the cause?
Flags: needinfo?(bob)
I always wondered about this packed.js file also.
The autophone versions just subprocess.Popen the test runner so I don't think there is anything special about how Autophone is running them. I think I only saw the 404s when I had connected the remote debugger to a run I did by hand with an unpacked tests zip file. There was nothing in the logs to signify that they were missing. I can try to investigate which functions packed.js defines and see where those are used and if we are getting them from some other file.
Flags: needinfo?(bob)
You're looking for bug 367393, FYI.
Thanks Ted. That certainly implies that we can remove packed.js and all references to it.
I'm happy to mentor this. Per comment 5, for this bug, the packed.js file needs removing, and all the references to it. See comment 0 for links.

You can run the tests with `./mach test path/to/test/or/dir`, but we'll also run them through the try server once a patch is posted.
Mentor: standard8
Keywords: good-first-bug
Whiteboard: [lang=xul]
Assignee: nobody → dbugs
Attachment #8857414 - Flags: review?(dtownsend) → review?(standard8)
Comment on attachment 8857414 [details]
Bug 1107904 - Remove packed.js and references to it as it is unused.

https://reviewboard.mozilla.org/r/129404/#review132126

Looks good. Thanks. r=Standard8
Attachment #8857414 - Flags: review?(standard8) → review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c69eea74cf6f
Remove packed.js and references to it as it is unused. r=standard8
https://hg.mozilla.org/mozilla-central/rev/c69eea74cf6f
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.