Port bug 1005456 to thunderbird / instantbird

RESOLVED FIXED in Thunderbird 37.0

Status

Thunderbird
Installer
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Nicolas Vigier, Assigned: Nicolas Vigier)

Tracking

Trunk
Thunderbird 37.0
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
When MOZ_ANGLE_RENDERER is defined but not MOZ_D3DCOMPILER_VISTA_DLL or MOZ_D3DCOMPILER_XP_DLL, an incorrect package manifest is generated. This is the case for instance when building with mingw-w64.

This was fixed on mozilla-central with this commit:
https://hg.mozilla.org/mozilla-central/rev/4d5ee95d4e54

Bug 1005630 fixed it for suite/installer/Makefile.in but the problem is still present in mail/installer/Makefile.in and im/installer/Makefile.in.

I will attach a patch in a following comment.
(Assignee)

Comment 1

3 years ago
Created attachment 8532574 [details] [diff] [review]
proposed patch

Comment 2

3 years ago
Thx for the patch! To get it moving ahead you should ask for review: (Try clokep@gmail.com?)
https://developer.mozilla.org/en/docs/Getting_your_patch_in_the_tree#Getting_the_patch_reviewed
Assignee: nobody → boklm
Status: UNCONFIRMED → ASSIGNED
Component: Build Config → Installer
Ever confirmed: true
(Assignee)

Updated

3 years ago
Attachment #8532574 - Flags: review?(clokep)
Comment on attachment 8532574 [details] [diff] [review]
proposed patch

Review of attachment 8532574 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks! :-) I'll check this in next time I'm on a computer!
Attachment #8532574 - Flags: review?(clokep) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/ddd557119648
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 37.0
You need to log in before you can comment on or make changes to this bug.