Update MarionetteTestRunner to locate mozinfo.json and import into runner framework

RESOLVED DUPLICATE of bug 1253618

Status

Testing
Marionette
P3
normal
RESOLVED DUPLICATE of bug 1253618
4 years ago
6 months ago

People

(Reporter: zac, Unassigned)

Tracking

({ateam-marionette-runner})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Mozinfo can import information from from an external json file and it can be used during the test run.

http://hg.mozilla.org/mozilla-central/file/18188c19a3c3/testing/mozbase/mozinfo/mozinfo/mozinfo.py#l150

Let's update MarionetteTestRunner to call this method, then we can pass json files with additional build information into jobs using this framework.
Keywords: ateam-marionette-runner
Created attachment 8535053 [details] [diff] [review]
Parse local mozinfo.json files in the Marionette test runner. v1.0

This patch is based on what mochitest is currently doing. I'm making the assumption that mozinfo.json will be present when the tests are executed in buildbot. Ted: As the author of this mozinfo method, can you confirm if this is a safe assumption?
Assignee: nobody → dave.hunt
Status: NEW → ASSIGNED
Flags: needinfo?(ted)
Attachment #8535053 - Flags: review?(mdas)
(Reporter)

Updated

4 years ago
Blocks: 1110846
Comment on attachment 8535053 [details] [diff] [review]
Parse local mozinfo.json files in the Marionette test runner. v1.0

Review of attachment 8535053 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8535053 - Flags: review?(mdas) → review+
This won't work completely out of the box unless you also make sure that mozinfo.json gets copied to the test package in the right place, like so:
http://dxr.mozilla.org/mozilla-central/source/testing/mochitest/Makefile.in#119
Flags: needinfo?(ted)
I believe there's more to do here, but I'm not actively working on this bug.
Assignee: dave.hunt → nobody
Status: ASSIGNED → NEW
[mass update] Setting Harness bugs to all P3
Priority: -- → P3
mozinfo support got implemented a while ago as part of bug 1253618.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253618
You need to log in before you can comment on or make changes to this bug.