[FTE][RTL] Telemetry page is not localized and not adopted for RTL language

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8532587 [details]
log12-05-2014.txt

Description:
In FTE, when switching to Arabic language, the Telemetry page is not localized and the checkbox is on the right side
   
Repro Steps:
1) Update a Unknown device to BuildID: 
2) Go through FTE settings until the "About Firefox OS" page
3) Observe the page

  
Actual:
The page is not localized and not adopted for RTL language
  
Expected: 
The page is localized and the checkbox is on the left
  

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141205040202
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: e7f3e6fee15e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: logcat, screenshot
(Reporter)

Comment 1

3 years ago
Created attachment 8532588 [details]
2014-12-04-19-58-08.png
(Reporter)

Comment 2

3 years ago
The issue DOES REPRO on 2.1 Flame
The page is not localized and the checkbox is on the right side

Device: Flame 2.1  (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141205001201
Gaia: 38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko: 8b92c4b8f59a
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
==================================================================
The issue does NOT repro on 2.0 Flame
The page is localized, but the checkbox is on the middle bug 1020525

Device: Flame 2.0  (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141205000201
Gaia: 856863962362030174bae4e03d59c3ebbc182473
Gecko: e40fe21e37f1
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(dharris)
Keywords: regression
I checked in with the l10n folks about this to get clarification. Historically, the Gaia repo has had a subset of locales allowing devs and testers to switch language and see Gaia apps translated/localized. That is no longer the case, all current translations and localization work takes place in the dedicated repo for that locale. The Arabic, French and Chinese languages we see in the gaia repo are *not* current and will eventually be removed. 

The pseudo-localizations are intended to allow l10n testing on the gaia repo. Once you enable pseudo-localizations in the developer settings, you can preview translation, right-to-left etc with the Accented English and Mirrored English pseudo-locales. For this particular case, as the telemetry opt-on screen gets correctly localized with accented english, and the checkbox gets flipped there is no bug to fix.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.