Per-folder address autocollect

RESOLVED INVALID

Status

--
enhancement
RESOLVED INVALID
17 years ago
9 years ago

People

(Reporter: risto.kankkunen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla has the cool feature of collecting addresses from messages arriving to
INBOX and storing them to a Collected Addresses address book. This helps
autocomplete to work even with small or no hand-maintained Personal address
books. There are some problems with this, though. Most notably the Collected
Addresses ends up having lots of unwanted addresses, e.g. from spam messages.

It would be very handy and powerful, if you could specify from what folders the
addresses are collected and into which address books they are stored. In the
folder properties, you could have an optional selection "Collect addresses from
messages of this folder into address book: <...>" with some kind of an address
book selector.

The default would be to have INBOX set to collect to "Collected Addresses",
other folders unset, to match the current behaviour.

First of all, this would help you control how autocomplete works. E.g. to avoid
spammer addresses getting collected, you would unset the INBOX collect and set
your other folders to be collected. Now you can delete spam messages from INBOX
and only messages you store to other folders are used to collect addresses.

Secondly and more importantly, this helps you manage your address books much
more easily. Let's say you have folders INBOX, Work and Friends. Now you could
set the Work folder to collect addresses to "Work Addresses" AB and Friends
folder to collect to "Friends Addresses" AB. When you read mail and archive it
to Friends or Work folders, new addresses are automatically added to the right
addressbook and are there for you to look or update.

Combined with bug 34340, this feature enables you to filter your incoming mail
almost automatically. Extending the previous example, you would add a filter to
move messages from INBOX to Work folder if From/To/Cc is in Work Addresses AB.
Make a similar filter for Friends. At first the address books could be even
empty. Now when you receive new mail, you read it and classify it by moving into
Work or Friends folders. The collect feature now adds the address from the
message to the corresponding AB. When you receive a message from the same
address again, the filter now matches and the message is moved into the right
folder. You don't have to change any of your settings after the initial
configuration! You just move the first message by hand and the rest will follow
automatically and your AB is updated automatically.

A specific use for this feature is spam filtering, as discussed in bug 71413
where I presented this idea first.

Comment 1

17 years ago
Duplicate of bug 62686, but this one has a better explanation.

Comment 2

17 years ago
*** Bug 62686 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
risto,

Thanks for the idea and info you have presented. It's a good one. Adding
Jeenifer to the cc list.

bhuvan
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1

Comment 4

17 years ago
Good idea for a future feature.

Comment 5

17 years ago
adding self to cc list

Comment 6

16 years ago
Please implement this.  I've got 1000 times more spammer addresses than real
ones in my collected addresses.
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
QA Contact: nbaca → addressbook
Target Milestone: mozilla1.0.1 → ---
Summary: [RFE]Per-folder address autocollect → Per-folder address autocollect
SeaMonkey specific as TB no longer has capability to collect incoming addresses.
Assignee: nobody → mail
Component: MailNews: Address Book → Address Book
Product: Core → Mozilla Application Suite

Comment 9

9 years ago
As said, this feature is gone. An extension called addressContext is available for a similar task.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.