Firefox hello conversations between guests with a password?

RESOLVED WONTFIX

Status

Hello (Loop)
General
--
enhancement
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: Guillaume Abadie, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Hi there!

I just discover the Firefox Hello service. What a great idea guys!

But I think there is an absolutely missing feature: As a guest when creating a conversation, I think we should be able to add a password if we wish. So that if we want to have a chat with someone who we are sharing some password together, it would make sure that absolutely nobody else could join in the conversation. 

Indeed, for now we have to send the hello.firefox.com URL throught another communication technology that might still be a third party service. But if the person you want to talk to and you, are both sharing a common secret password, then we would be sure that no third party you have been using to send the URL could also join in.

And even if you don't have a common password with that person, it would be great to have a password generator so that you can send using another communication service (let say, mobile phone text messaging...). This way, all third party would have only the URL or the password, and both persons would still be anonymous.

Also, I have not been testing, but could it be a conference room? I mean, if there is already 2 persons talking, can a third be joining in? If it can, it would be great that the guest who has created the conversation can automatically or manually grant (or not) others who might want to join in.
Component: General → General
Product: Mozilla Services → Loop
QA Contact: anthony.s.hughes

Comment 1

4 years ago
feature request - put on backlog so we can go through with product team in the new year.
backlog: --- → backlog

Updated

4 years ago
backlog: backlog+ → backlog-
Duplicate of this bug: 1144993
The URL effectively is the password for a Hello conversation: if you don't know the URL, you can't enter the conversation, and it's encrypted using a portion of the URL so that no one can decrypt your conversation.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.