[Video] Pausing a video will make the controls disappear unless video is resumed.

RESOLVED INVALID

Status

Firefox OS
Gaia::Video
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-flame-reduced-run], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8532740 [details]
logcat_20141205_1655.txt

Description:


Prereq: At least one video on device.

Repro Steps:
1) Update a Flame to 20141205040202
2) Launch Video App
3) Play a Video
4) Pause video.
5) Observe that the control buttons UI will disappear.

Actual:
Video controls will disappear such as the option to scrub through video. Unpause button is still accessible by pressing the play button in the middle of the screen.

Expected:
It is expected that the control buttons will still be accessible after pausing a video.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141205040202
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: e7f3e6fee15e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency: 100%
See attached: Logcat & Video
Video: http://youtu.be/D9rQDdFmGho
(Reporter)

Comment 1

3 years ago
This issues DOES occur on the Flame 2.1 KK (319mb) and the Flame 2.0 KK (319mb)
Result: Video controls will disappear such as the option to scrub through video. Unpause button is still accessible by pressing the play button in the middle of the screen.

Flame 2.1

Device: Flame 2.1 (319mb) (Kitkat Base)(Full Flash)
BuildID: 20141205001201
Gaia: 38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko: 8b92c4b8f59a
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Device: Flame 2.0 (319mb) (KitKat Base)(Full Flash)
Build ID: 20141205000201
Gaia: 856863962362030174bae4e03d59c3ebbc182473
Gecko: e40fe21e37f1
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Comment 2

3 years ago
Correction, Step 2 should read "2) Launch the Gallery App."  and not the Video app. This issue only occurs in the Gallery App. The Video app appears to be fine.
It seems that the gallery settings toolbar is shown instead of the video controls. Unsure of the expected design here. NI Gallery owner to see if this intended or not
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(npark)
I remember when paused, it should show the video slider UI, but I can't remember for sure. Pinging jsavory for UI check.
Flags: needinfo?(npark) → needinfo?(jsavory)
Forwarding this one to Tiffanie as she is UX lead on Gallery and Video.
Flags: needinfo?(jsavory) → needinfo?(tshakespeare)
I think this may be redundant with these other two bugs?
https://bugzilla.mozilla.org/show_bug.cgi?id=1011795
https://bugzilla.mozilla.org/show_bug.cgi?id=836831
Flags: needinfo?(tshakespeare)
This is no longer reproducible in master, qawanted for status on 2.2 and 2.1
Keywords: qawanted
This issue still reproduces on Flame Master, 2.2, and 2.1. the controller disappears when the video is paused. Instead, the gallery menu bar appears instead.

Note that this issue occurs in Gallery app, NOT in Video, as the original reporter corrected on Comment 2. This might not be a valid bug, as the user can easily resume the video by pressing the play button on the screen.

Environmental Variables:
Device: Flame Master
Build ID: 20150429164621
Gaia: db8ea705c0fd1b1684807f5a8e837bb9a36a6f96
Gecko: 4b9b12c248dc
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
Build ID: 20150429203150
Gaia: aa1da5036f9425c25d515d14243d3473bfefb4fd
Gecko: 38b2838d43e1
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1
Build ID: 20150429180123
Gaia: 7cd76434b58be2cfef7d23451e668c76591f05c3
Gecko: b5d2472c2940
Version: 34.0 (2.1)
Firmware Version: v18D-1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
As observed, the playback controls are getting replaced with gallery toolbar actions when the video is paused. This is to spec - that's not to say the design/interaction can't or shouldn't be improved, but it does make this fall out of bug territory and land more in the feature request or backlog bucket.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.