Firefox beta 35.0 now starts playing H.264 files on mac but only audio is played, video is not shown

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: JJ, Unassigned)

Tracking

35 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141201162954

Steps to reproduce:

I tried playing several H.264 video sources on Mac, vimeo and also local files like below:

Track # 1 Info - TrackID 1 - TimeScale 100000 - Duration 00:58:00.360
Media Info: Language "English" - Type "vide:avc1" - 87009 samples
Visual Track layout: x=0 y=0 width=1280 height=720
MPEG-4 Config: Visual Stream - ObjectTypeIndication 0x21
AVC/H264 Video - Visual Size 1280 x 720
	AVC Info: 1 SPS - 1 PPS - Profile High @ Level 4.1
	NAL Unit length bits: 32
Self-synchronized



Actual results:

I hear audio being played, never video is shown


Expected results:

both audio and video should be played back
(Reporter)

Comment 1

3 years ago
Using preferences in about:config

And enabling:
media.peerconnection.video.h264_enabled;true

I do see H.264 video, so this might be a non-issue?
Component: Untriaged → Video/Audio
Product: Firefox → Core
Component: Audio/Video → Audio/Video: Playback
H.264 support added for Mac in 38.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.